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Entries

File entries

Create folders

You want to create a new folder in ELO.

Method

Open the Repository work area.

Select the folder in the repository that you want to create the new folder in.

Select New folder on the New tab.

1. 

2. 

3. 
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The Metadata for new folder dialog box opens. The Folder form is selected by default.

Information

In the Metadata for new folder dialog box, you only see forms in the Available forms

column that have been assigned the Folders usage option in the metadata form

manager of the ELO Administration Console.

Enter the name of the new folder in the Short name field.

Information

The more detailed your entries are, the easier it will be for you to locate the folder.

Once you have entered the required information, select OK.

Result

A new folder is created.

Outlook

The folder can be used for filing documents or for creating additional child folders.

4. 

5. 
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You can save an existing folder structure as a default index and insert it into other folders. A

default index is used as a template and can be used as often as required. You will find more

information in the Save as default index section.

File document

You have the following options for storing a document in ELO:

Via drag-and-drop

With the 'Insert file' function

Scan it to the Intray and file it

With the 'Document from template' function

File a document with drag-and-drop

You want to drag and drop a document to ELO from Windows Explorer.

Method

Open the Repository work area in ELO.

Open Windows Explorer.

Click the document in Windows Explorer and drag it to the desired target folder.

Alternative: You can file multiple documents to ELO. Select the documents while holding

SHIFT or CTRL in Windows Explorer and drag them to the desired target folder.

Release the mouse button.

• 

• 

• 

• 

1. 

2. 

3. 
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The Metadata for new document dialog box opens.

Select a metadata form in the Available forms column.

Enter a short name.

Optional: Enter additional metadata.

Alternative: For multiple documents, you can enable the Same metadata for all documents

(serial filing) option below the Short name field. Refer to chapter Serial filing for more

information.

Information

The more precise the information is that you enter for a document, the easier it is to

find the document later on. For detailed information on this topic, refer to the 

Metadata chapter.

Select OK once you have entered all metadata.

Result

You have filed the document to ELO.

Outlook

5. 

6. 

7. 
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You can modify documents stored in ELO. If the document is version-controlled, a new version of

the document is stored after you have made changes. The old version is retained. You have the

following options:

Check out and edit document

Load new version

Store document with the 'Insert file' function

You want to transfer a document from your file system to ELO.

Method

In the Repository work area, select the folder that you want to insert the document into.

On the ribbon, select New > Insert > Insert file.

In the Insert file dialog box, select the desired file.

Alternative: You can file multiple files to ELO. Select the desired files while holding the SHIFT

or CTRL key.

The Metadata for new document dialog box opens.

Select a metadata form in the Available forms column.

• 

• 

1. 

2. 

3. 

4. 

5. 
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Enter a short name.

Optional: Enter additional metadata.

Alternative: For multiple files, you can enable the Same metadata for all documents (serial

filing) option below the Short name field. Refer to chapter Serial filing for more information.

Information

The more precise the information is that you enter for a document, the easier it is to

find the document later on. For detailed information on this topic, refer to the 

Metadata chapter.

Select OK once you have entered all metadata.

Result

You have filed the document to ELO.

Outlook

You can modify documents stored in ELO. If the document is version-controlled, a new version of

the document is stored after you have made changes. The old version is retained. You have the

following options:

Check out and edit document

Load new version

Scan a document to the Intray and file it

You want to scan a document and file it to ELO.

Requirements

A scanner needs to be connected to the computer.

Please note

If you are using the 64-bit version of ELO, you will need to use the ELOscanTool for scanning.

You will find this setting under Ribbon > User menu [your name] > Configuration >

Technical presets > General > Use as scan method > ELOscanTool TWAIN (Windows).

Method

Open the Intray work area.

Place the document in the scanner.

Select the Scan document button on the File tab to start the scan process.

6. 

• 

• 

• 

1. 

2. 
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Optional: A dialog box may appear. Make the desired settings and select Scan.

The scan is performed.

The scanned document appears in the viewer pane.

File document

Follow these steps to file the scanned document to ELO.

Select the scanned document in the Intray work area.

On the File tab, select File to ELO.

1. 

2. 
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The File to ELO dialog box opens.

Select the folder where the scanned document should be filed.

Select OK.

3. 

4. 
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The Metadata for new document dialog box opens.

Select a metadata form in the Available forms column.

Enter a short name.

Optional: Enter additional metadata.

Information

The more precise the information is that you enter for a document, the easier it is to

find the document later on. For detailed information on this topic, refer to the 

Metadata chapter.

Select OK once you have entered all metadata.

Result

You have filed the document to ELO.

Outlook

You will find more information about the functions on the File tab in the File entries via the Intray

chapter.

5. 

6. 

7. 
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You can modify documents stored in ELO. If the document is version-controlled, a new version of

the document is stored after you have made changes. The old version is retained. You have the

following options:

Check out and edit document

Load new version

Store document with the 'Document from template' function

You want to create a new document with the help of a document template.

Requirements

Templates must be created in an application such as Microsoft Word.

There must be a document template in ELO, e. g. for Microsoft Word documents.

You must know the name of the folder in ELO containing the document templates.

Information

The Templates function (available in: Ribbon > View > Navigation) enables you to

jump to the folder with the document templates in ELO. Specify the filing location of

the folder with the document templates on the Ribbon > User menu [your name] >

Configuration > Technical presets > Folder for document templates.

You must know where you want to store the document in ELO.

Information

Assuming you have the corresponding permissions, you can define a central folder for

templates in ELO. You will find this setting under Ribbon > User menu [your name] >

Configuration > Technical presets > Folder for document templates.

Method

Open the Repository work area.

Select the folder in the tree structure that you want to file the document to.

On the ribbon, select New > Insert > Document from template.

Keyboard shortcut: CTRL + N

• 

• 

• 

• 

• 

• 

1. 

2. 

3. 
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The Document from template dialog box opens.

Open the folder with the document templates and select the appropriate template.

Select OK.

4. 

5. 
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The Metadata for new document dialog box opens.

Select a metadata form in the Available forms column.

Enter a short name.

Optional: Enter additional metadata.

Information

The more precise the information is that you enter for a document, the easier it is to

find the document later on. For detailed information on this topic, refer to the 

Metadata chapter.

Select OK once you have entered all metadata.

The dialog box closes. The corresponding external application will start and the document

template will be displayed.

Make the desired changes.

Save the document and close the external application.

The document is now located in the designated folder in ELO.

Select the document in ELO.

6. 

7. 

8. 

9. 

10. 

11. 

12. 

14 ELO Java Client



On the ribbon, select Document > Check in.

Keyboard shortcut: ALT + I

The Version information dialog may appear. If so, enter a version number and a version

comment.

Result

You have filed the new document to ELO.

Outlook

You can modify documents stored in ELO. If the document is version-controlled, a new version of

the document is stored after you have made changes. The old version is retained. You have the

following options:

Check out and edit document

Load new version

Create dynamic folder

The Dynamic folder function (available in: Search work area > Ribbon > Search > Result) enables

you to save a previous search request as a dynamic folder in the Repository work area. Only

entries that match the search criteria are displayed in a dynamic folder. If a new document is filed

to ELO that matches the search criteria, the new document is automatically displayed in the

dynamic folder. For example, you can display all invoices with the status Unpaid in a dynamic

folder.

Dynamic folders are saved in the Repository work area. You can save them to any location here.

Default index

Save as default index

Available in: Repository work area > Ribbon > Organize > Structure

This function saves the folder structure of the selected folder as a default index. A default index is

used as a template and can be used as often as required.

You can apply the default index to other folders via the Insert default index function. Documents or

child folders with more than two levels are not saved.

Method

Select the folder that contains the child structure you want to save as a default index.

On the ribbon, select Organize > Structure > Save as default index.

• 

• 

1. 

2. 
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The Save as default index dialog box appears.

Enter a name for the new default index.

Optional: Select the desired options in the check boxes. You have the following options:

Also copy child structures from the template to the default index: If this option is

enabled, all child structures in the selected folder are transferred to the default index.

Also copy documents from the template to the default index: If this option is enabled,

all documents in the selected folder are transferred to the default index.

Show new default index for all users: If this option is enabled, the default index is

available to all (global) users. If not, it is only available to the (local) user who created

it.

Global default indexes are stored under Administration//Default Indexes.

Local default indexes are stored under <User> // data // Default Indexes.

Select OK.

Result

The default index is stored and is available via the Insert default index function.

Outlook

To delete an existing default index, select the Delete default index function in the Repository work

area (available in: Ribbon > Organize > Structure). The Delete default index dialog box opens.

Select the default index you want to delete.

3. 

◦ 

◦ 

◦ 

4. 
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Insert default index

Available in: Ribbon > Organize > Structure

Use this function to insert a default index into a folder. A default index is a predefined child

structure within a folder, e.g. a tab with a company name, months, A-Z.

Requirement: You must have created at least one default index before you can perform the

following steps. You can do this with the Save as default index function.

Method

Open the Repository work area.

Select the folder that you want to add a default index to.

On the ribbon, select Organize > Structure > Insert default index.

The Insert default index dialog box appears.

Select the desired default index.

1. 

2. 

3. 

4. 
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Result

The default index is inserted into the folder.
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Edit metadata

The Metadata function (available in: Ribbon > Organize tab) allows you to view the metadata for

the entry.

If you have permission, you can edit the metadata.

Metadata is data about a folder or a document.

It includes information on the entry itself, for example when it was filed, or its name in the 

Repository work area. It also includes the permissions structure for the entry, meaning who has

what access to the entry. The quality of a repository depends to a great extent on the quality of the

metadata. Metadata allows you to organize documents in a standardized way and file them quickly

to ELO. In addition, using metadata makes it easier to find documents.

A new metadata model was introduced with version ELO 21 in addition to the previous metadata

model. Both models are used in parallel. In the following, these metadata models are referred to as

generation 1 (gen. 1) and generation 2 (gen. 2).

In gen. 2, forms and metadata forms are shown differently in the Metadata dialog box. The

metadata concept will remain the same.

There are three ways to open the Metadata dialog box manually. Select an entry and

select Organize > Metadata on the ribbon.

right-click to open the context menu, then select Metadata.

press the keyboard shortcut F4.

This section provides information about entering metadata. Select one of the following links to go

straight to a topic:

Metadata forms

Fields

'Basic' tab

'Extra text' tab

'Options' tab

'Permissions' tab

'Version history' tab

'Additional information' tab

Identify personal data

Delete entries with personal data

Enter metadata with ELO Click OCR

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Information

If the ELO Barcode module is installed, ELO can extract metadata from barcodes. You can

find more information on the ELO Barcode module and configuring it in the ELO

Administration Console in the ELO Barcode documentation.

Metadata forms

You enter metadata into metadata forms. Metadata forms contain templates that are specifically

created for this document type. All documents of the same type receive the same permission

settings and are filed to ELO based on a fixed pattern.

The view and functions in the metadata forms depend on the metadata model.

Gen. 2 metadata form

Gen. 1 metadata form

20 ELO Java Client
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The Available forms area lists all the available metadata forms. The list contains either metadata

forms for folders or for documents, depending on the type of entry selected in ELO.

Information

You can minimize the Available forms pane by selecting the Hide metadata forms icon

(arrow icon pointing left). You can select the Show metadata forms button (arrow icon

pointing right) to make the pane reappear.

Please note

When you change the metadata form, metadata may be lost or incorrectly assigned.

Fields

The metadata for a document is entered into fields.

The type of field determines the data you need to enter and what you need to consider when doing

so. There are different types of fields, which can be configured differently from metadata form to

metadata form.

Text field: You can enter letters, numbers, and special characters in a text field.
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Mandatory field: Fields can be configured as mandatory to complete the metadata entry. A red

asterisk and a red marking indicates that a field is mandatory. Any conflicts are displayed at the

bottom of the dialog box.

Please note

Do not enter any words that can act as search operators (NOT, OR, AND) in fields. Otherwise,

you may encounter issues when searching for these words.

Icons

If a field contains an icon, this means that ELO helps you to enter content in the field.

The following tools are available:

Keyword list

Drop-down menu

Calendar

Clock

Relation

Keyword lists

Keyword lists are used to standardize entries and make it easier to enter metadata.

There are two types of fields with keyword lists:

You have to select an entry from the keyword list.

You can select an entry from the keyword list or you can type in your own entry.

If you click a field and a keyword list appears, you cannot make entries.

Information

The following functions are only available in the gen. 1 metadata forms.

You can enter multiple keywords in these fields, separating them by a pilcrow sign (¶).

• 

• 
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Please note

Keywords containing a pilcrow sign are treated like a list of keywords, as pilcrow signs are

used as a separator between multiple values.

Expand keyword list automatically: If this option is enabled, the keyword list opens as soon as you

start to type text into a field.

Information

You can can either click the check box to enable the Expand keyword list automatically

option or use the keyboard shortcut CTRL+K.

If the Expand keyword list automatically option is disabled, you need to open the keyword list using

the list icon at the bottom of the index field.

Alternative: Open the keyword list using the F7 key.

To edit the keyword list, right-click a keyword list entry.

You can add new keyword list entries or child entries via the context menu. You can edit or delete

existing keyword list entries or child entries.

In the Keyword list editor dialog box, you change the name of a keyword.

The following options are also available:
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Merge keyword: If a keyword has child entries, you can use this option so that the child entries are

always inserted into the field together with the parent keyword. The parent keyword option must

be enabled for this to work.

For example, if your keyword list contains the keyword Invoice with the child entries Miller and 

Smith, either the expression Invoice Miller or Invoice Smith will be used. You can only choose

between the child entries of the keyword.

Disable keyword: Use this option to deactivate a keyword. The keyword can no longer be selected

and will be grayed out.

Relations

Relation type fields are used to link a field with the metadata of another entry.

The chain icon opens a list of entries. Select the entry you want to link. Navigate the list using the

mouse or arrow keys.

Click the title of a column to sort the list. You can hide and show columns using the context menu,

which you access by right-clicking in the column titles.
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Clicking the arrow next to the chain icon takes you straight from the metadata of the entry to the

metadata of the linked entry. Alternatively, right-click on the relation field to open the context

menu and select the Go to button. The metadata of the linked entry is displayed in the Metadata

dialog box.

Additional functions in the 'Metadata' dialog box

The Metadata dialog box offers the following additional functions:

Undo (CTRL+Z)

The keyboard shortcut CTRL+Z undoes the last action in a field.

Alternative (gen. 1 only): Click the Undo function in the context menu of the field (right-click).

Redo (CTRL+Y)

The keyboard shortcut CTRL+Y reapplies the last action that was undone in a field.

Alternative (gen. 1 only): Click the Redo function in the context menu of the field (right-click).

The following functions are also available for gen. 1 metadata forms:

Automatically enter metadata

Pin function

Use last entry

Insert column index separator

Load metadata

Save metadata

These functions are briefly explained in the following section.

• 

• 

• 

• 

• 

• 
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Automatically enter metadata

The Enter metadata using the most recently saved/displayed entries [F3] button (icon with the

green arrow) enables you to apply the metadata that you entered or opened last.

Alternative: Call the function using the F3 key.

Information

The data in the fields File name, Entry type, and Document path are not overwritten with

this function. The original data is retained in these fields.

Pin entry to field (Intray only)

To enter the same value to a field in multiple documents in the Intray, enable the function Pin entry

to field using the F8 key.

Alternative: Click the Pin entry to field function in the context menu of the field (right-click).

A pin icon appears.

As soon as you file the next document with the same field, the value you entered previously will be

applied.

Please note

The value is only saved for the current session. The ELO Java Client does not "remember"

the value once you have closed the program.

Use last entry

To reuse a value from a field the next time you enter metadata, use the F9 key.

Please note
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The value is only saved for the current session. The ELO Java Client does not "remember"

the value once you have closed the program.

Insert column index separator

To save multiple values to a field, separate the values with a pilcrow character (¶). Use the

keyboard shortcut CTRL+P.

Alternative: Click the Column index separator function in the context menu of the field (right-click).

Load metadata

This button enables you to load a metadata file (.es8) into the current metadata for the document.

Metadata of an ELO entry is stored in ES8 files.

Alternative: Call the function using the keyboard shortcut CTRL+L.

Information

When you load an ES8 file into the metadata, the existing metadata is overwritten without

showing a confirmation.

Save metadata

Select this button to save the metadata of the current folder or document as an ES8 file.

Alternative: Call the function using the keyboard shortcut CTRL+S.
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Tabs

Metadata forms are divided into tabs. There are several default tabs:

Basic

Extra text (only in gen. 1 metadata forms)

Options

Permissions

Version history

Additional information

The default tabs are briefly described in the following section. Additional tabs appear depending on

the settings in the metadata form.

'Basic' tab

The Metadata dialog box opens to the Basic tab. It contains at least the following default fields:

Short name: Name of the entry that is shown in the tree structure in the Repository work area.

Document date (gen. 2)/Date (gen. 1): The document date refers to the date the associated file

was last accessed. The document date is updated when changes are made to the document.

You can also edit the document date manually using the calendar function.

In gen. 1 metadata forms, you can enter information into this field using the following syntax:

+x = today in X days

+xd = today in X days (d for days)

+xm = today in X months (m for months)

+xy = today in X years (y for years)

To enter a past date, use - (minus) instead of + (plus).

Example 1

Entering +1m on Dec 2, 2019 returns the date Jan 2, 2020. If you were to enter -1y, this would

return the date Dec 2, 2018.

ELO also automatically completes the following entries:

05 is returned as <current month> 05, <current year>

Dec 5 is returned as Dec 5, <current year>

Example 2

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Entering 31 on December 2, 2019 returns the date December 31, 2019.

Filing date: The filing date refers to the date the document is filed to ELO.

Version (gen. 2)/Current version (gen. 1): Shows the individual version number (if entered). This is

not the internal version counter.

Editor: Shows the user who last edited the document.

For folders only:

ELOINDEX: This field is for the filing definition. When filing documents automatically, ELO identifies

where to file the document through the ELOINDEX.

'Extra text' tab

Information

This tab only appears in gen. 1 metadata forms.

In this text field, you can enter information that is not covered by the other fields, for example a

more exact description or a comment. The field can also be used for script settings.

'Options' tab

The Options tab is where you specify the characteristics and behavior of an entry. Depending on

whether you are entering metadata for a document or a folder, different settings will be displayed.
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General options

The following options are available for all folders and documents on the Options tab:

Information

You will find more information on the Personal identifier, End of deletion period, and End of

retention period fields in the chapters Identify personal data and Delete entries with

personal data.

Sensitivity: You can choose one of five sensitivity levels for the entry. The sensitivity level is shown

in the viewer pane above the document preview.

Please note

If you have configured a sensitivity level for an entry, you can change the sensitivity level,

but you cannot remove it.

Entry type: This option is used to specify the type of the entry, e. g. a Word or PDF document. This

setting determines the icon that is displayed in the list view in ELO.

Font color: Select a color for the entry to improve the visual clarity of your repository structure.
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Translate short name: If this option is enabled, the short name of the entry is translated into the

selected display language.

Please note

In order for the translation to be displayed, a translation for the short name must have been

entered in the translation table. You also need to configure the metadata form. If necessary,

contact your system administrator.

Start point for replication: This option enables you to specify a folder as the starting point for

replication. The next time replication takes place, the folder is placed in the Replication Base of the

target repository. The administrator must insert the new folder at the desired location in the target

repository. This enables you to replicate parts of repositories even if they have not been filed in

identical structures. You will find more information in the ELO Replication documentation.

Object ID and GUID: The first number in this field is the internal ELO object ID. This entry is

primarily for information purposes and cannot be changed. The object ID is required when testing

the checksum, for example.

The character string in brackets specifies the GUID of the entry. The GUID (Globally Unique 

Identifier) is a unique identification number. This is automatically assigned and cannot be modified.

This enables you to identify every entry uniquely, even outside of the repository.

Filed by: The user who created the entry is entered here.

Options for documents

The following options are only available for documents:

Document status

Document path

Encryption

Add to full text database

Approval document

File name

Document status: Select the editing status of the entry from the drop-down menu:

Version control disabled: Only one version of the document is saved. The previous version is

deleted and is no longer available.

Important

If you select this option, the previous version is overwritten each time you save. The 

Document > Versions > Load new version function overwrites the current version,

and does not create a new one. For this reason, we do not recommend using this

option.

• 

• 

• 

• 

• 

• 

• 
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If you attach files to documents without version control, only one file can be attached.

Attaching another file overwrites the first attachment.

Version control enabled: If the document is edited, a new version is created. All changes are

documented. Older versions can be restored.

Non-modifiable: ELO does not allow changes to the document and its metadata.

Warning

The document status Non-modifiable cannot be reversed.

Document path: This is the document path (storage path) that has been set for the entry.

Encryption: You can select an encryption key here if you want to encrypt documents. This is

recommended, e. g. if documents should only be available to a specific set of users. The

encryption key password must be entered when opening a document. Encryption keys are defined

by your administrator. You will find more information here: Encryption keys.

Important

The encryption process is irreversible. Encrypted documents remain encrypted.

Add to full text database: Enable this option to add the document to the full text database. This

function indexes words so that they are available in the search.

Approval document: If this option is enabled, new versions of the document do not automatically

become the working version. Users with the right Author for approval documents determine which

version of the document should be the working version.

Two attributes separate an approval document from a normal document.

After editing, a new version is created when checking in a document. The new version is not

automatically set as the working version. To set a document version as the working version,

use the function Set as working version (Ribbon > Document > Document versions).

Before editing an approval document, the Check out and edit dialog box opens. In this dialog

box, users can choose whether they want to check out and edit the working version or the

newest document version.

File name: The file name of the document as stored outside of ELO, for example.

Options for folders

The following options are only available for folders:

Sort order

Enable quick preview for documents in the folder

• 

• 

• 

• 
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Sort order: This is where you can define how the contents of the corresponding folder will be

sorted:

Filing date: The entry with the most recent filing date is at the bottom.

By filing date descending: The entry with the most recent filing date is at the top.

Alphabetical: Entries are sorted ascending from A to Z.

Alphabetical descending: Entries are sorted descending from Z-A.

Date: The entry with the most recent document date is at the bottom.

By date descending: The entry with the most recent document date is at the bottom.

Manual: You can move the entries within the folder manually. To do so, the folder must be

opened in the list view.

Enable quick preview for documents in the folder: Use this option to view the first document in a

folder in the viewer pane as soon as you click the folder.

'Permissions' tab

The users that have access rights to the selected entry are listed on the Permissions tab. You can

change the settings, provided you have the corresponding permission.

Information

You can access and edit the permissions for an entry directly using the Permissions function

(available in: Ribbon > Organize > Properties).

• 

• 

• 

• 

• 

• 
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Add user/group: Search for the desired user or group in this field. Suggestions will appear as you

type.

Select the corresponding suggestion to select a user or a group.

Alternative: If you select the triangle to the right of the Add user/group field, this will open a drop-

down menu. This menu contains a list of the users and groups you selected recently.

In the middle column, you can see which users or groups have already been assigned permissions

for the selected entry and which permission settings apply.

To edit the permissions settings, select an entry in the middle column and select or clear individual

permissions.

The following options are available:

Access right Description

View (R) View entries and metadata, add annotations

Change

metadata (W)

Delete (D)
Mark entries as deleted. Only users with administrative rights can delete entries

permanently.

Edit (E)

Documents: Edit documents, e.g. check in, check out, load new version,

change working version.

Folders: No effect. If this access right is granted to folders, entries stored

in them can automatically inherit this access right.

Edit list (L)
Folders: Change folder contents, e.g. create, move, copy, or remove documents

in the folder, insert or delete reference.

Set permissions

(P)
Change permissions

Information

Options that are not applicable are shown in italics and enclosed in pointy brackets.

Personal (orange user icon): Use the Personal button to assign yourself sole access to the

respective entry. All other permissions will be revoked.

AND group: AND groups are useful if you only want to assign permissions to the users in a group

that are also members of another group. To create an AND group, select two groups in the middle

column and select AND group.

Group members: If you select a group, a list of members appears.

Double-click the corresponding user in the Members of the group column to select a member of a

group.

• 

• 
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Remove permissions: To remove all permissions from a user or group, select the X icon next to the

selected user or group.

Please note

Keep in mind that when you revoke your own read permissions on an object, you can no

longer see the entry in the repository. If you remove the Set permissions right, you will no

longer be able to edit the permissions settings.

Permissions for entries in spaces

There are additional authorization options for entries that were created in a space.

You can find more information on spaces in the Spaces section.

Authorization only for members of the space <space name>: Users and group members granted

this permission can only access the entry if they are members of the corresponding space.

Information
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This option only appears for entries created in a space. For entries created elsewhere but

displayed in a space, the permissions of the entry in the repository apply.

If you enable this option, the permissions granted to group members according to their role in the

space overlap with the access rights granted in the Metadata dialog box.

The permissions to the entry at the individual user level also overlap in accordance with this.

You can see the permissions in effect when you select a user or group in the Metadata dialog box.

Example

A user has the Member role in the Positions and candidates workspace. Members have RWDEL

access rights for entries. The user is also a member of the Team leader group. In the Metadata

dialog box, this group has all access rights for the entry.

The user only has RWDEL access rights for this entry because only these access rights overlap.

Other members of the Team leader group will not have access to the entry unless they are also

members of the workspace.
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Grant a non-member access to an entry

You can grant users who are not members of a space access to entries in the space. Users can

open these entries from the search or with ELO links, for example.

Example

The head of HR wants to grant a head of department access to an application created in the HR

workspace. The head of department needs to be able to read the application and edit the

metadata. The head of HR can add the head of department on the Permissions tab and assign him

the R and W access rights.

Outlook

If you change the permissions of a folder in the Metadata dialog box, the new permissions can be

passed on to the child entries (child folders and documents). After you have changed the

permissions, the Permissions changed dialog box opens. Specify what effects this change should

have.
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Please note

The changes do not affect references, since they retain the permission settings of the

original entry.

Choose from the following options:

Do not pass on permissions: The changes are not applied to the documents and child folders in the

folders.

Pass on permissions to child entries: All permissions are passed on to the entries in the folder.

Only apply changes, keep other permissions: Only permissions are passed on that result in

changes to permissions for the documents and child folders in the folder.

Apply to: Using the drop-down menu, select whether to apply the changes to all child entries or

only folders/documents.

'Version history' tab

With version-controlled documents, changes to the metadata are documented. You will find this

documentation on the Version history tab.
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The version history contains two panes:

In the top part, you can see which users made changes and when.

The changes that the selected user made are shown in the lower part.

'Additional information' tab

Information

This tab is only displayed if you have been granted authorization by an administrator.

The Additional information tab provides additional fields in the database (map fields). These fields

can be used for scripts, workflows, and other purposes.

Identify personal data

The Options tab in the Metadata dialog box contains three fields that allow you to find entries with

personal data and delete them in due time.

Personal identifier: If the entry contains a personal identifier, enter information that enables you to

identify the relevant person in this field. This term is intended to help you find the entry using the 

metadata search. For this reason, you need a company-wide system for assigning these terms.

This will help you find entries containing a user's personal data. You can also search all entries

containing personal data – regardless of the individual.
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End of deletion period: Enter the date on which the entry must be deleted at the latest. This date

must come after the date you have entered under End of retention period. You can select a date

using the calendar icon in the field.

Please note

If you do not complete the Personal identifier and End of deletion period fields, a dialog box

will appear indicating that a personal identifier has not been specified. You can disable this

dialog box under Ribbon > User menu [your name] > Configuration > Dialog boxes.

End of retention period: Enter the date up to which the entry has to be retained. The entry cannot

be deleted before the entered date. You can select a date using the calendar icon in the field.

Please note

The retention period must end before the deletion period.

Information

You can set a retention period in the ELO Administration Console. If an entry is filed with the

corresponding metadata form, the field End of retention period is completed automatically.

Delete entries with personal data

The purpose of marking entries with personal data is to be able to delete the corresponding entries

in accordance with legal requirements. You can delete entries with personal data in the following

ways:

Via the search

With the Delete expired documents function

Method using the search

To delete entries with personal data, first perform a search. You can narrow down your search

based on the End of deletion period or End of retention period fields.

In the search results, select the entries that have to be deleted. To select multiple entries,

press the CTRL key and click all the entries you want to select. If you want to select all

entries or all entries you want to select are in a row, press the SHIFT key then click the top-

most and bottom-most entry you want to select.

Once you have marked the entry or entries in the search results, select Organize > Delete on

the ribbon. Select Delete in ELO in the selection dialog box.

Result

The entries can no longer be seen in the Repository work area.

• 

• 

1. 

2. 

3. 
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Important

The entries are not deleted permanently, just marked as deleted. This tells the

administrator that the documents need to be removed from ELO permanently. You can find

more information under Show deleted entries and Delete permanently.

Method using the 'Delete expired documents' function

Please note

The function Delete expired documents not only deletes entries containing personal

identifiers, but all entries whose retention period has passed.

On the ribbon, select Organize > System > Delete expired documents.

The Delete expired documents dialog box appears.

Specify whether you want to delete Documents only or Documents and folders with expired

retention periods.

Result

The entries can no longer be seen in the Repository work area.

Important

The entries are not deleted permanently, just marked as deleted. This tells the

administrator that the documents need to be removed from ELO permanently. You can find

more information under Show deleted entries and Delete permanently.

Enter metadata with ELO Click OCR

The integrated text recognition feature can be used as a tool for entering metadata. ELO Click OCR

transfers text from a document into the metadata form. This prevents users from making manual

data entry errors. The following example explains how to proceed.

Click OCR can be used in all work areas. In this example, we demonstrate how the function works

in the Intray work area.

Information

An OCR service needs to be installed for ELO Click OCR to work.

Method

Open the Intray work area.

Select the document that you want to edit the metadata of.

1. 

2. 

1. 

2. 

41 ELO Java Client



The document appears in the viewer pane.

Select Organize > Move on the ribbon.

The Metadata dialog box opens.

Select the desired metadata form.

Click the field you want to apply the metadata to.

The cursor blinks in the selected field.

Move the mouse pointer to the part of the document (preview) containing the information

you require.

Information

If ELO Click OCR recognizes a text element (word or number), the element that has

been found is highlighted in yellow and a tooltip with the recognized text appears.

Click the text you want to transfer to the metadata form.

Information

If you want to transfer multiple terms after another, select each individual term while

holding the SHIFT button. Release the mouse button after each term. Repeat the

process until you have transferred all desired terms.

Result

The recognized text information is transferred to the selected field.

List permissions

Available in: Repository work area > Ribbon > Organize > Properties

The List permissions function enables you to view the permissions for each folder in ELO. This

function helps administrators to quickly find information on the permission structures in the

repository.

3. 

4. 

5. 

6. 
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Information

The function is only available for folders. You will find information on the permissions of a

document on the Permissions tab in the Metadata dialog box.

In this dialog box, you see the permissions for a selected folder including its child entries.

Filter: In the drop-down menu, select which child entries (All entries, Folders only or Documents

only) you want to view the permissions of.

Including references: Select the option Including references if you also want to list permissions for

references.

Selected folder: Shows the folder you selected.

Progress: While the system is searching for permissions for the selection you made, a green bar

appears next to Progress to indicate the expected duration of the process.

The column below Progress lists the permission sets found in the selected folder. If you expand one

of the sets (triangle symbol), you can see which child entries use this permissions set.

Go to: The Go to button takes you straight to the respective entry in ELO.
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Open in read-only mode: Select Open in read-only mode to open the respective document in an

external application.

Add user/group

Search for the desired user or group in the Add user/group field. Suggestions will appear as you

type.

Click the corresponding suggestion to select a user or a group.

Alternative: If you select the triangle to the right of the Add user/group field, this will open a drop-

down menu. This menu contains a list of the users and groups you selected recently.

In the middle column, you can see which users or groups have already been assigned permissions

for the selected entry and which permission settings apply.

Edit permissions settings

To edit the permissions settings, select an entry in the middle column and select or clear individual

permissions.

The following options are available:

Access right Description

View (R) View entries and metadata, add annotations

Change

metadata (W)

Delete (D)
Mark entries as deleted. Only users with administrative rights can delete entries

permanently.

Edit (E)

Documents: Edit documents, e.g. check in, check out, load new version,

change working version.

Folders: No effect. If this access right is granted to folders, entries stored

in them can automatically inherit this access right.

Edit list (L)
Folders: Change folder contents, e.g. create, move, copy, or remove documents

in the folder, insert or delete reference.

Set permissions

(P)
Change permissions

Information

Options that are not applicable are shown in italics and enclosed in pointy brackets.

Personal (orange user icon): Use the Personal button to assign yourself sole access to the

respective entry. All other permissions will be revoked.

• 

• 
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AND group: AND groups are useful if you only want to assign permissions to the users in a group

that are also members of another group. To create an AND group, select two groups in the middle

column and select AND group.

Members of the group

If you select a group, a list of members appears.

Double-click the corresponding user in the Members of the group column to select a member of a

group.

Remove permissions

To remove all permissions from a user or group, select the X icon next to the selected user or

group.

Apply: Select Apply to save the changes. The dialog box remains open.

OK: Select OK to save changes and close the dialog box.

Cancel: Select Cancel to close the dialog box without saving the changes.
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Edit entries

Edit entry

You can edit the content of documents in ELO. To do so, you must check out the document, and

check it back into ELO when you have finished working on it. You can Check out and edit a single

document or an entire folder. When an entry is checked out (folder or document), it is locked and

cannot be edited by other users.

Check out and edit document

You want to edit a document and file the new version to ELO.

Method

Open the Repository work area.

Select the document you want to edit.

The preview of the document is displayed in the viewer pane.

On the ribbon, select Document > Check out and edit.

Keyboard shortcut: ALT + O

The document is opened in the corresponding application and can be edited.

In ELO, the name of the user who currently has the entry checked out is shown in square

brackets before the document name. The document cannot be edited by other users as long

as it is checked out.

Edit the document in the external application.

Save the document in the external application.

Close the external application.

Information

1. 

2. 

3. 

4. 
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You can file the edited document to ELO via the Repository work area or the In use

work area. Select the Check in function on the Document tab.

Select the document in ELO.

Select the Check in function on the Document tab to transfer the document back to ELO.

Keyboard shortcut: ALT + I

Alternative: Right-click a document in the repository and select Check in from the context

menu.

Information

If you do not change a document and select the Check in function, the Check in

document dialog opens. In this dialog box, you can cancel editing or file the document

as a new version anyway.

The Version information dialog box appears.

Optional: Enter a version number and version comment.

7. 

8. 

47 ELO Java Client



If you want to update the document date in ELO to the current date, select the Apply the

current date option. The document date is the date that is saved along with the document

version. In contrast, the filing date is the date on which a document was filed to ELO.

Users with the appropriate permissions can delete versions of a version-controlled

document. If you do not want your version to be deleted, select the Non-deletable version

option.

Select OK.

Result

The document is checked back into the Repository work area with a new version number.

Related functions

Load new version: With this function, you can also load a new version without checking out

and editing the current version of a document filed to ELO.

Check out to OneDrive: Use this function to check out a Microsoft Office document in ELO to

Microsoft OneDrive for editing. The document is stored in your OneDrive folder until you

check it back into ELO.

Check out and edit folder

ELO also lets you check out entire folders and edit their contents. This allows you to lock multiple

documents at once.

Please note

If you check out a folder with all the references, you cannot check in the references

separately. Instead, you need to check in the entire folder. In addition, you cannot check in

the original documents that are linked to the references until you have checked in the entire

folder.

Method

Open the Repository work area.

Select the folder you want to check out.

Right-click the folder to open the context menu.

In the context menu, select the Check out and edit function.

9. 
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The folder is temporarily stored in a checkout directory on your file system. You can open

and edit the individual documents from here.

Information

Child folders are not checked out. A file in ES8 format is created for each document.

Files in ES8 format are used for saving metadata. The Windows Explorer default

settings hide ES8 files.

The entire folder appears as checked out in the In use work area.

Check in

When you have finished editing the documents, you can check the folder back into ELO.

Select the checked out folder in ELO.

Right-click the folder to open the context menu.

Choose the Check in function in the context menu.

During check-in, ELO recognizes which documents have been changed. With the default

settings, the Version information dialog box appears for every changed document.

Result

The folder was checked in. The changed documents were filed as new versions.

Load new version

Available in: Ribbon > Document > Versions

5. 
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You can also load a new version if you did not check out and edit the current version of a document

filed to ELO.

The Load new version function enables you to load a file from your local file system and store it as

a new version of a document in the Repository work area. Using this option on version-controlled

documents creates a new entry in the version history and makes this new version the current

working version. In the case of documents that are not version controlled, the previous version is

overwritten.

The following options are available for loading a new version:

Load new version function

Drag-and-drop (left-click and hold the mouse to drag a new document to a document in ELO

and release the mouse button)

Document versions

Available in: Ribbon > Document > Versions

Use this function to open an overview of the existing document versions for the selected entry. The

current working version is displayed in bold type. The current working version is the version with

the pen icon in the Working version column.

Among other things, you can open document versions in read-only mode, compare versions, set

them as the working version, and delete them.

• 

• 
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The following functions are available:

Open in read-only mode: Opens the selected version in an external application.

Save as: Use this function to save versions to your local file system.

Compare: Select two versions by holding down the CTRL key and select Compare. The versions are

shown next to each other in a new window.

Check signature: Checks the signature of a selected version. The signature module must be

installed.

Set as working version: This option sets the selected version as the working version. A working

version is the currently used version.

Set as non-deletable: The selected version is set as non-deletable.

Delete version: Deletes the selected version. The version is initially assigned a deletion marker and

can be restored (as long as it has not been permanently deleted).

Information

To view deleted versions, enable the Show deleted entries function (Ribbon > Organize >

Delete).

Restore: Removes the deletion marker from a deleted version.

Edit comment: To edit the comment for a version, double-click the corresponding comment field.

Edit document

Keyboard shortcut: CTRL + E

Use this function to open a document that is in the In use work area but is not currently open in the

corresponding external application.

Save your changes in the external application and then transfer the document to ELO using the 

Check in function (available in: Ribbon > Document).

Discard document changes

Available in: Ribbon > Document > Versions

Use this function to delete the current working version of a document and restore the original

version.

This function is only available for documents that you have checked out.

Compare documents

Available in: Ribbon > Document > Verify
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Use this function to open two documents next to each other in a new window. This allows you to

compare the two documents directly.

To use this function, select two documents in the Content tab of an ELO folder while holding down

the CTRL key.

Convert documents

Create preview document

Available in: Ribbon > Document > Convert

Use this function to create a preview document in TIFF or PDF format for the currently selected

document. The preview document is a special image document that is stored separately in ELO.

Use this function to display documents if there is no viewer for the original format. You can use this

for CAD files, for example.

Use the Show preview document option to view the preview document. You will find the Show

preview document function under Ribbon > View > Display.

Show preview document

Available in: Ribbon > View > Display

The preview document is a special image document that is stored separately in ELO. Use this

function to display documents if there is no viewer for the original format. You can use this for CAD

files, for example.

You will find more information here: Create preview document.

PDF conversion

Available in: Ribbon > Document > Convert

Requirement: An ELO PDF Printer must be installed.

Use this function to convert a document selected in ELO into a PDF document. The document is

filed to the repository as a new version.

TIFF conversion

Available in: Ribbon > Document > Convert

Requirement: An ELO TIFF Printer must be installed.

Use this function to convert a document selected in ELO into a TIFF document. The document is

then filed as a new version of the original document.
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Add attachment

Available in: Ribbon > Document > Attachment

This function enables you to transfer a file from your local file system and attach it to an ELO

document. The local file is copied to ELO and linked to the document stored in ELO.

You will recognize an attachment by the paper clip icon of the Open attachment button.

To open the attachment, select the Open attachment button.

Information

If you add a second attachment to a document, you can only access the first attachment

using the Attachment versions function.

Related functions

Open attachment in read-only mode: Opens an attachment in the corresponding external

application, such  as Microsoft Word.

Attachment versions: Opens an overview of the versions of an attachment.

Save attachment as: Saves the attachment outside of ELO in your local file system or on an

external storage medium.

Delete attachment

Attachment versions

Available in: Ribbon > Document > Attachment

Use this function to open an overview of the attachment versions. You can open, store, compare, or

delete individual attachments. In addition, you can check the signature of an attachment and

restore a deleted attachment.

• 
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The following options are available:

Open in read-only mode

Save as: Saves versions of the attachment selected in a list of versions outside of ELO.

Compare: To compare two versions, select two entries in the versions overview list and then

select Compare.

Check signature: If you have signed attachment, you can check the signature with this

function.

Set as working version: This option sets the selected version as the working version. A

working version is the currently used version.

Set as non-deletable: The selected version is set as non-deletable.

Delete version: Deletes a version selected in the list.

The version is highlighted in red after deletion.

Restore: Restores a deleted version (marked red).

The version is restored to the list and is no longer highlighted.

OK: Saves any changes and closes the dialog box

Add and search annotations

Add annotations

Annotations include sticky notes, text notes, and stamps. Annotations are affixed to a single page

of a document. You can only place annotations, text notes, and sticky notes on documents that can

be displayed in the document viewer (PDF, TIFF, JPEG, ...).

The following example shows how to do this using a sticky note. The method is similar for other

types of annotations.

Information

To use stamps, you must have been assigned at least one stamp by the administrator.

You can also create custom stamps that only you can use.

Information

You can use the Create margin note function if you want to add a note on an entire

document or on a document in another format.

Requirements

• 
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You need a document that can be displayed with the document viewer, e.g. a PDF or image

file.

Method

Select the document that you want to place an annotation on.

The document is shown in the viewer pane.

Information

You can assign permissions so that not all users can see or edit annotations. You will

find the permissions settings for sticky notes and text notes under Ribbon > User

menu [your name] > Configuration > Annotations.

You define the permission settings for stamps in the Stamps overview dialog box. You

will find more information in the Add stamps section.

The document viewer toolbar is displayed above the document in the document viewer.

Apply a sticky note

Select the sticky note icon on the document viewer toolbar to enable the Sticky note

function.

Information

To use an annotation function multiple times in succession, hold down the CTRL key or

the ALT GR key as you click the function. To return to normal mode, choose the Select

function (cursor icon).

1. 
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Optional: To change the color, click the triangle next to the sticky note icon and select a

different color from the drop-down menu.

The cursor turns into a sticky note in the color you selected.

Click the part of the document you want to place the sticky note on.

The sticky note is created. The dotted border indicates that the sticky note can be edited.

The editor and the current date are displayed below the sticky note.

Enter text.

Click the area outside of the sticky note.

Result

The text you entered is saved. The sticky note is displayed on the document.

Information

You can use the context menu to open e-mail addresses, ELO links, and web pages in a

sticky note (Available in: Right-click > Open links).

Outlook

Double-click the sticky note to edit it. To delete a sticky note, select the sticky note with the

selection tool and then select Delete in the document viewer toolbar.

Add stamps

You can create new stamps or edit existing ones.

Information

Default stamps cannot be edited or deleted.

Method

3. 

4. 

5. 
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In the viewer toolbar, select the triangle icon next to the stamp icon.

In the drop-down menu, select the Stamps overview button.

The Stamps overview dialog box opens.

Select Add.

The Add stamp dialog box opens.

In this dialog box, select the name as well as the text or image for a stamp. The following

settings are available:

Date: The current date is added to the stamp text. Appears in the text field as 

%d{dd.MM.y}.

Other usable formats: Select the triangle icon to open examples of other time

and date formats.

Time: The current time is added to the stamp text. Appears in the text field as %X.

User: The name of the user is added to the stamp text. Appears in the text field as %u.

Font

Permissions: You can set who can see the stamps here.

Please note

These permissions do not define who is allowed to use the stamp.

Select OK to save the stamp.

Result

The stamp appears in the drop-down menu that you open using the triangle icon next to the stamp

icon.

Outlook

You can select the stamp you want to use from the drop-down menu.

To edit stamps of your own, select a stamp in the Stamps overview dialog box and choose Edit.

Search annotations

The Search metadata function can be used to search for margin notes and annotations.

Requirements

There must be at least one document in ELO that contains an annotation or margin note.

2. 
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Method

Open the Search work area.

On the ribbon, select Search > Search logic > Search metadata.

Keyboard shortcut: CTRL + F

The Search metadata dialog box opens. The default search form is selected.

Optional: Select a different search form if required.

Select the Options tab.

Enter a search term in the Notes search field.

Information

If you want the search to include annotations that do not contain any text, enter an

asterisk (*) in the search field.

1. 
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Optional: You can select the type of notes you want to search for from the drop-down menu

under the Notes field.

Select OK.

Result

The search starts. The search results appear in the Search work area.

Add margin note

You can create margin notes for a document or a folder under Ribbon > Document > Margin note.

Margin notes are displayed on the split bar. If you hover over the margin note with the mouse

pointer, the text, the creation date, and the editor are displayed.

There are three types of margin notes:

General margin note (yellow): Can be seen and edited by all users.

Personal margin note (green): Only the creator can read and edit this type of margin note.

Permanent margin note (red): Can be read by everyone, but cannot be edited or deleted.

You can use the margin note icon to open the margin note and read it or edit it again.

You can use the context menu to open e-mail addresses, ELO links, and web pages in a margin

note (Right-click > Open links).

A margin note applies to the entire entry and not just the current version.

Create signature

Available in: Ribbon > Document > Verify

Use this function to digitally sign documents.

Requirement: Suitable third-party software and hardware must be installed.

5. 
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Check signature

Available in: Ribbon > Document > Verify

Use this function to check the digital signature of a document. The function is only available if the

document has a digital signature.

Test checksum

Available in: Ribbon > Document > Verify

This function verifies the checksum of the selected document. The checksum indicates whether

the document has been transferred correctly to ELO. This function creates a hash value of the

document. This value is checked for changes to guarantee that the document has not been

changed.
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Search entries

You can search for entries (folders or documents) in ELO.

There are different ways to find documents in ELO. You can either use ELO iSearch or the metadata

search.

For general information about the search, refer to the Program interface > Search chapter.

Input

Enter one or more search terms into the input field.

Matching search terms are suggested as you type. To accept a suggestion, double-click on the

term.

Information

You will find tips for entering search terms by selecting more under the input field.

Select Start search to search for the term.

Select the Reset search button to restore the default search settings.

Narrow down search

The following options are available for narrowing down your search:

Areas

Folders

Filters

Narrow down areas

You can limit your search to specific areas.

• 
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• 
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Do this by selecting in all areas and choosing the areas.

If you have selected multiple areas, the search behaves as follows:

One search term:

If you enter one search term, entries containing the search term in one of the areas are

shown.

Multiple search terms:

AND search: With an AND search (entering terms without a connecting element, e. g. dog

cat), all entries that contain all search terms in one of the searched areas are shown.

OR search: With an OR search (entering terms with a comma, e. g. dog, cat), all entries that

contain at least one search term in one of the searched areas are shown.

Information

For technical reasons and to improve ELO iSearch performance, these areas cannot be

searched in combination in the AND search.

Example

You search for two terms in different areas: One of the terms is in the full text of a

document, and the other is in the short name. ELO iSearch does not return any matches. In

this case, it only lists results that include all search terms in the same area.

If you search for just one of the terms and restrict the search using filters, you will get

better results.

Narrow down folders

You can narrow down the search to a single folder.

• 
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Information

For technical reasons, this option may cause the search results to take a long time to load.

In the Repository work area, select the folder you want to search.

Switch to the Search work area.

On the ribbon, select Search > Search logic > Current folder only.

Make additional settings as required.

You need to select Start search again for the restrictions for a previously performed search to take

effect. If you select the Current folder only option, the searched folder is displayed in a tooltip.

Display search results

In the Search work area, you can use the same functions on entries as in the Repository work area,

for example edit documents, create tasks, or send entries.

To go to the filing location of the selected entry, select View > Go to on the ribbon.

The search results are shown in multiple columns when the default settings are used. The table

columns correspond to the fields of the metadata forms. The results can be filtered within the

columns. By clicking the column headers, the results can be sorted in ascending or descending

order.

1. 
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Context menu

Right-click a column header to open a context menu. Select the columns that you want to display.
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Numeric values

ELO provides the following additional information in the context menu for columns that only

contains numeric values.

Sum: Calculates the column sum.

Minimum: Returns the lowest value in a column.

Maximum: Returns the highest value in a column.

Filters

You can apply filters to the columns of the search results.

• 
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You can access the filters via the arrow icon next to the column label.

Highlighted full text matches

Matches are highlighted in the full text preview. Switch to the Full text option in the viewer pane.

If the document contains more than one match, you can jump back and forth between the matches

in the full text using the Show next hit (arrow pointing downwards) and Show previous hit (arrow

pointing upwards) buttons.

You can also display the hits in the Results text table column. Enable the Results text option under 

Ribbon > User menu [your name] > Configuration > Display > Search.

Display mode for search results

With the default settings, the search results are displayed as a list. You can also view search results

as a tile, table, or tree structure. You can access the settings via Toolbar > Display options.
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Outlook

You will find more information on the search here:

Program interface > Search: General use, wildcard search, phrase search

Search a business object

For business objects, you start a search within the region of a business object via the search field

in the viewer pane. The system then searches for the entered short name. The search is restricted

to the region of the business object, including the associated child folders.

Filters

ELO iSearch offers the option of adding filters. These filters can be used to refine the search.

You can access the filters under Ribbon > Search.

• 
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ELO iSearch provides the following filters:

Metadata form: Filters the search by the selected metadata form.

Entry type: Filters the search by the selected entry type (e.g. folder, image document, Word

document).

Date: Filters the search by the selected document date.

Filed by: Filters the search by the user that filed the entries.

All fields: Enables the user to search in all fields.

Select field: Enables the user to search a field in a metadata form. You can select multiple

fields in a form by holding down the CTRL key.

Feed: Enables the user to search posts and hashtags within the ELO feed.

Editor: Filters the search by the user entered as the editor in the Metadata dialog box.

Filing date: Filters the search by the selected filing date.

File size: Filters the search by the selected file size.

Search spaces: Enables you to run a search in a selected space.

• 
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Please note

If you search for NOT, OR, or AND via the search field or filters, you may encounter issues

during your search.

Enable/disable filter

Click to enable or disable the filter. You will recognize an active filter based on the button's darker

color. As soon as you have enabled a filter, the corresponding field appears below the search field.

Click the arrow icon to the right of the field to open a drop-down menu for selecting options.

The selection options vary depending on the filter.

The selected setting appears in the filter field.

The filter becomes active when you start a search.

Alternative: Select Reset search to filter the search results for a search that has already run.
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Combine filters

You can combine filters.

Multiple filters: By combining different filters, you can narrow down the search results based

on multiple criteria. This allows you to create precise search requests.

Multiple filters of one type: Use multiple filters of the same type to set more advanced filters.

For example, multiple Entry type filters allow you to perform a search filtered by multiple

entry types.

Negate filters

You can set filters to exclude specific values.

• 

• 
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Right-click the filter field to open the context menu. In the context menu, enable the option does

not contain.

The filter is now in is not mode.

Remove filters

Use the X icon next to the selected filter value to remove it.
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Filter with date

Use the Date and Filing date filters to filter your search by a specific date or period. Both filters

apply the same principle.

This type of filter offers the following options:

Input field: To select a specific date, click the corresponding date in the calendar.

Alternative 1: Enter the date manually in the input field. The following pattern is recommended:

MM/DD/YYYY.

Alternative 2: Enter the period manually in the input field. The following rules apply:

Past: If you enter a minus sign and a number, the corresponding period in the past is

selected.

• 
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Future: If you enter a plus sign and a number, the corresponding period in the future is

selected.

Months: If you add an m to the number value, the period is calculated in months instead of

days.

Examples

For example, if you enter the value -14, the filter applies the setting Last 14 days.

In contrast, if you enter the value -6m, the Last 6 months setting is applied.

Range: Selecting Range opens two additional input fields (from and to). Use these fields to define a

period of time. Manually enter the start and end date or select them using the calendar.

Today: Select Today to automatically select the current date.

Last 10 days: Selecting Last 10 days automatically sets the period to the last 10 days.

Last 30 days: Selecting Last 30 days automatically sets the period to the last 30 days.

Last 3 months: Selecting Last 3 months automatically sets the period to the last 3 months.

Show calendar (small calendar icon): Selecting Show calendar opens a calendar in the middle of

the drop-down menu.

Show list of years (list icon): Selecting the Show list of years button opens a list of years in the

middle of the drop-down menu. To select one or more years as a date range, enable the

corresponding check boxes.

• 
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Filter: Numeric

Metadata fields with the file type Number can be filtered by number values and number ranges.

Enter the desired number value or number range in the filter input field.

To enter a number range, you have the following options:

<: To enter a number range less than a specific number, enter the less-than symbol (<) and

the number.

>: To enter a number range greater than a specific number, enter the greater-than symbol

(>) and the number.

...: To enter a range between two numbers, separate these numbers with three periods (...).

• 
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Save search

You can also save searches as favorites. There are two ways to start a new search with a search

favorite:

From the Search favorites drop-down menu on the Search tab

From the search favorite tile in My ELO

Search favorites are automatically saved in the Search favorites drop-down menu and as a tile. You

can find the tile in the tile navigation of My ELO under Hidden tiles.

If you click a search favorite, the search term is applied to the search field. You can start a new

search with the search favorite.

Manage search favorites

Available in: Search work area > Ribbon > Search > Search favorites

Use this function to rename or delete a search favorite.

Use the arrow icons to change the order of the favorites in the drop-down menu.

Select the Delete button to delete the selected favorite. The favorite is initially marked red. The

favorite is deleted once you select OK, closing the dialog box. If you close the dialog box with the 

Cancel button, the delete action is reversed.

Search metadata

Available in: Search work area > Ribbon > Search > Search logic

Keyboard shortcut: CTRL + F

This function enables you to search the fields of metadata forms.

In addition to using the ELO iSearch, ELO enables you to search the metadata using metadata

forms. The metadata search allows you to search for specific metadata.

Information

If you want to use a metadata form for the search, your administrator first has to enable the

corresponding setting.

• 
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The following options are available in the Search metadata dialog box:

Form selection

All metadata forms that can be used as a search form are displayed in the Available forms area.

Select the metadata form that you used to file the document you are searching for, e. g. Invoice.

This limits the search to documents that have been assigned this metadata form.

Information

The Filter field enables the user to browse or filter the Available forms area.

Dashboards

In the Search work area, buttons are available that allow you to launch dashboards after

conducting a search with a form filter. These buttons are only displayed if dashboards have been

configured for the corresponding metadata form.
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Dashboards are created by the administrator. They can only be created with generation 2

metadata.

The dashboards allow you to visualize metadata of entries filed with the same metadata form in

different ways. You can use bar charts, line charts, doughnut charts, and key figures.
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Move the cursor over the charts on the dashboard to view details.

Search fields

The search fields of the metadata form are shown on the corresponding tab. They correspond to

the fields on a metadata form. The tabs and search fields that appear depend on the settings for

the corresponding search form.

You can use the search fields to search specifically for the entries in these fields, such as for the 

Invoice number or the Filing date.

Information

When searching the metadata, it is possible to make entries to multiple fields of a search

form. This allows you to create complex search queries.

For example, enter the status Unpaid in the Status field. ELO then searches exclusively in the 

Status input field of the documents that were filed with the Invoice metadata form.
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Information

You can use keyword lists for entering search terms.

Options

The Options tab provides additional options to restrict the search to specific criteria.

Personal identifier: Use this field to search the contents of the Personal identifier field. Enter the

term you entered in the metadata. If you want to search all entries with a personal identifier, enter 

* to the search field.

End of deletion period: These two fields enable you to restrict the search to entries with a specific

deletion period.

End of retention period: These two fields enable you to restrict the search to entries with a specific

retention period.

Entry type: This enables you to restrict the search to specific entry types (e. g. folders, PDF, Word

document).

Notes: Allows users to search for notes. Select the note type from the drop-down menu.

Search range: The options in the Search range define what is to be searched.

Search mode: The search mode is important when you use multiple fields for the search. Use the 

Search mode drop-down menu to specify whether the fields are linked with Boolean AND or with

Boolean OR.

AND: Only matches meeting all criteria are returned.

OR: All matches meeting at least one of the criteria are returned.

Filed by: Allows users to restrict the search to entries by specific users.

File name: Allows users to restrict the search to entries with a specific file name.

Start search

Select the OK button when you have completed the search form.

Previous searches

• 
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If you have already carried out multiple search requests, selecting Enter metadata using the most

recently saved/displayed entries [F3] (icon with green arrow) will open a list of previous search

requests. Both the search term and the field used are displayed.

Select one of the listed entries followed by OK. The terms will then be transferred to the search

form.

AND/OR search in fields

To search fields using AND/OR links, the search terms must be placed in quotation marks. One of

the operators (AND or OR) must be placed between the search terms.

Remove from search results

Available in: Search work area > Ribbon > Search > Result

Use this function to remove individual entries from the list of search results. The entries remain

unchanged in ELO. If you perform the same search again, then all matches will be displayed.

Recent search requests

Available in: Search work area > Ribbon > Search

ELO saves the ten most recent search requests. Click the search request to run the search again.

The search requests are saved when you close ELO.

The menu contains previous ELO iSearch requests and metadata search requests.

Current folder only

Available in: Search work area > Ribbon > Search > Search logic

Use this function to restrict the search to the folder selected last in the Repository work area. You

need to select Start search again for the restrictions for a previously performed search to take

effect. If you select the Current folder only option, the searched folder is displayed in a tooltip.

Please note

If the Current folder only option is enabled, the search can take a lot longer.
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Show deleted entries

Available in: Search work area > Ribbon > Search > Search logic

To search exclusively for deleted entries, enable the function Show deleted entries. If the Show

deleted entries option is enabled (highlighted yellow), you will ONLY see deleted entries in the

search results.
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Organize entries

Move

Available in: Repository work area

You can link entries (folders or documents) within the tree structure.

The following options are available for moving entries:

'Move' function

Drag-and-drop

'Move' function

Method

Select the entry you want to move.

On the ribbon, select Organize > Move.

The Move tab opens. The selected entry is displayed in the Original field.

Select the target folder in the tree structure.

The selected folder is displayed in the Target folder field.

Select Move entry.

If the permissions of the entry do not match the permissions at the target location, the Move

entries dialog box opens. You can modify the permissions of the moved entries in this dialog

box.

Optional: You can also save your selection so that the dialog box doesn't appear the next

time you run the function. You can change your selection in the configuration (available in: 

User menu [your name] > Configuration > Dialog boxes > Inherit permissions when moving

entries).

Result

The entry is moved to the target folder.

Drag-and-drop

Method

• 
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Click the entry you want to move and drag it to the target folder holding down the mouse

button.

The Drag-and-drop dialog box opens.

Choose whether you want to move or reference the entry. A reference ascribes to an entry.

Optional: You can also save your selection so that the dialog box doesn't appear the next

time you run the function. You can change your selection in the configuration (available in: 

User menu [your name] > Configuration > Dialog boxes > Drag-and-drop).

Reference

Available in: Ribbon > Organize > Structure

Use this function to create a reference to a document or folder selected in ELO. A reference is a link

between a copy of an original document. The document only exists once physically in ELO. All

changes to the document automatically apply to the references. This prevents duplicates.

The following options are available for referencing entries:

'Reference' function

Drag-and-drop

Information

You can automatically store entries in dynamic folders or reference them. For more

information, refer to the File entries chapter.

'Reference' function

Method

Open the Repository work area.

Select a document or a folder.

On the ribbon, select Organize > Structure > Reference.

The Reference tab opens.

The name of the selected document or folder is displayed in the Original field. You will be

asked to select a target folder in ELO.

Select the folder in ELO that you want to create the reference in.

2. 
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The folder is displayed in the Target folder field.

Select Insert reference.

Result

The Reference tab closes. The reference is created in the selected target folder.

An arrow icon indicates that it is a reference.

Drag-and-drop

Method

Click the entry you want to reference and drag it to the target folder holding down the

mouse button.

The Drag-and-drop dialog box opens.

Choose whether you want to reference or move the entry.

Optional: You can also save your selection so that the dialog box doesn't appear the next

time you run the function. You can change your selection in the configuration (available in: 

User menu [your name] > Configuration > Dialog boxes > Drag-and-drop).

Copy

Available in: Ribbon > Organize > Structure

Use this function to copy the currently selected entry to the clipboard. You can copy an individual

document, a folder or a folder structure with child folders. The Insert copy function enables you to

insert an entry at the desired location in ELO.

Method

Select the entry in ELO that you want to copy.

Select Organize > Structure > Copy.

The Copy/Paste tab opens.

Select the target folder in ELO.
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The target folder is entered in the Target folder input field.

Select Insert copy.

Depending on whether you have copied a document or a folder, the corresponding Insert

copy dialog box opens.

When copying documents or folders, you can choose from various options. For example, you

can specify whether you want to keep the notes, the references, or the permissions.

Select OK.

Result

The copy is inserted in the target folder.

'Insert copy' dialog box

Insert copy of a document

If you want to insert the copy of a document, you have the following options under Copy.

Notes: If this option is enabled, notes are copied as well.

All document versions: If this option is enabled, the version history of the documents is copied as

well. Otherwise, the current working version is copied.

4. 
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Attachments: If this option is enabled, the current attachments are copied as well.

Attachment versions: If this option is enabled, the version history of the attachments is copied as

well. Otherwise, the current attachment is copied.

Insert copy of a folder

If you want to insert the copy of a folder, you have the following options under Copy.

Basic entry only: If this option is enabled, only the selected folder without child entries is copied.

Folder structure only: If this option is enabled, the folder structure is copied without documents.

Folder structure with documents: If this option with documents is enabled, the folder structure and

the documents in it will be copied.

References: If this option is enabled, references are copied as well.

Notes: If this option is enabled, notes are copied as well.

All document versions: If this option is enabled, the version history of the documents is copied as

well. Otherwise, the current working version is copied.

Attachments: If this option is enabled, the current attachments are copied as well.

Attachment versions: If this option is enabled, the version history of the attachments is copied as

well. Otherwise, the current attachment is copied.

Permissions

You can make the following settings for documents as well as folders:

Replace with the permissions of the target folder: The permissions of the copied entries are

ignored and replaced by the permissions of the target folder.

Keep previous permissions unchanged: The copied entries keep the existing permissions.

Replace permissions inherited from the previous folder, keep individual permissions: The

permissions of the copied entries are replaced with the permissions that apply for the target folder.

Permissions that were not inherited from the original folder are retained.

Retain user in "Filed by" and "Editor" field: The users entered in the Filed by and Editor fields are

copied from the original entries.

Monitor changes

Available in: Ribbon > New > Create task

This function enables you to keep track of changes to a document or folder. If another user creates

a new version of the document being monitored or if another user adds an entry to the folder

being monitored, you will be notified in the Tasks work area.
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Information

If you are monitoring a folder, you will be notified as soon as another user has created a

new document or new child folder within this folder. When you monitor folders, you are not

notified of changes to their child folders. To monitor changes to a child folder, you have to

monitor the child folder specifically.

You can make the following settings:

Name: Enter a name for the entry being monitored. The name of the selected entry is

entered by default.

Priority: Set the importance of the monitoring instance: A (= high), B (= medium), and C (=

low). You can sort and filter the task list according to priorities.

Note: Enter a note that appears in your Tasks work area.

You can recognize notifications by the camera icon.

To remove the notification from your task view, select the notification, then select Organize > 

Delete on the ribbon.

Monitoring overview

You can open an overview of entries you are monitoring under Ribbon > Organize > Overviews.

You can edit or end monitoring actions here.

To start monitoring on an entry, use the Monitor changes function (available in: Ribbon > New >

Create task).

• 
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The following functions are available in the Monitoring overview dialog box:

Go to: Opens the filing location of the selected entry.

Open in read-only mode: Opens the respective document in an external application

Edit monitoring: This opens the Edit monitoring dialog box. In this dialog box, you can

change the name, priority level, and notification settings of a monitoring action that appears

in your tasks area.

End monitoring: Ends monitoring of the current entry. The entry being monitored is initially

marked red. When you select OK, the dialog box closes and the entry is no longer monitored.

If you close the dialog box with the Cancel button, the delete action is reversed.

Link

You can link entries (folders or documents) that are related. This enables you to access an entry

from another entry using the link. If two entries are linked, the Link icon is displayed.

• 
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Information

In the Tree and table layout mode, you can show the Link column in the table. A link icon is

also displayed in this column if a link exists for an entry.

Method

Select a document in the Repository work area.

Select View > Navigation > Link.

The Link dialog box opens.

Select a second document in the Repository work area. In the Link dialog box, select the Add

the selected entries as links button (arrow facing right).

The second document is added as a link.

The following functions are available in the Link dialog box:

Go to: Jump straight to the respective entry in the Repository work area.

1. 
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Open in read-only mode: Open the respective document for viewing in an external application.

Mesh links: If an entry is linked with multiple other entries, you can link all of the entries with this

function.

Permanent link: The link to the selected entry is permanent. Permanent links cannot be deleted.

Remove: Deletes a selected entry from the list of links. The links to the entries are removed.

OK: Select OK to link the entries and close the dialog box.

To edit an existing link, click the Link icon.

Move document files

Available in: Ribbon > Organize > System

The Move document files function enables you to move files, file versions, attachments, and/or

attachment versions to another medium (i. e. to a different document path). The repository

structure remains the same.

Selection

Preselection in the repository: Indicates which folder was selected in the Repository work area.
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Select document paths

Source path: Select the source path if you only want to move files from a specific path.

Target path: Define the target path. If the desired target path does not exist, it needs to be created

in the ELO Administration Console.

Settings

From date: Enter the date on which you want to start moving files.

to: Enter the date on which you want to end moving files.

Move referenced documents as well: If this option is enabled, documents for which references exist

in ELO are also moved to another path.

OK: To move the document files, select OK.

Font color

Available in: Ribbon > Organize > Properties

Use this function to change the font color of a selected document or folder.

Sort order

Available in: Repository work area > Ribbon > Organize > Properties

Use this function to change the sort order within a selected folder. You can choose between

different sort orders in a drop-down menu:
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Sort manually

If you select the option Manual, you can sort the child entries in the folders later on.

Select a view profile that includes the Content view element.

Click the folder that you want to sort manually.

Optional: If you have not already done so, open the Content view element.

In the Content view element, click the entry (folder or document) that you want to move.

Drag and drop the entry to the selected location.

The sort order is changed.

Information

You will find other options for sorting entries in the list and tile view on the toolbar.

Delete

Keyboard shortcut: CTRL + DEL

This function enables you to delete

entries in the Repository work area

Warning

The entries (folders or documents) are not deleted permanently. They are hidden and

marked for deletion. This tells the administrator that the documents need to be

removed from ELO permanently. To delete entries permanently, use the functions 

Show deleted entries and Delete permanently. They can be restored until the point at

which they are permanently deleted.

workflows, monitoring actions, and reminders in the Tasks work area

Only the task is deleted. The corresponding entry remains in the repository.

Please note

Documents in the Intray that have not yet been filed to ELO are permanently deleted with

the Delete function.

Outlook

The function Delete expired documents enables you to delete entries whose retention period has

passed. You can enter the retention period in the metadata when you file the entry.
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Show deleted entries

Available in: Ribbon > Organize > Delete

Use this function to show deleted entries. Deleted entries are entries that have been removed with

the Delete function and that have a deletion marker. Entries with a deletion marker are hidden in

ELO.

If you show deleted entries, [deleted] is displayed after the name of the deleted entry. The Restore

function enables you to revert the deletion process and remove the deletion marker. Use the 

Delete permanently function to permanently erase deleted entries.

Restore

Available in: Ribbon > Organize > Delete

Use this function to remove the deletion marker from an entry in ELO. This allows you to undo the

deletion of an entry. This option is only available if the entry has not been deleted permanently.

To restore deleted entries, you must first show the entries again in ELO. Use the Show deleted

entries function to do this. The entries are marked with [deleted] before the short name. Select an

entry marked with [deleted] and select Restore. The deletion marker is removed.

If you restore a deleted folder, you can use the Restore entries deleted on or after option to define

a date limit from which the documents included and deleted in the folder are restored.

Delete expired documents

Available in: Ribbon > Organize > System

Use this function to delete entries whose retention period has passed.
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Warning

The entries (folders or documents) are not deleted permanently. They are hidden and

marked for deletion. This tells the administrator that the documents need to be removed

from ELO permanently. To delete entries permanently, use the functions Show deleted

entries and Delete permanently. They can be restored until the point at which they are

permanently deleted.

Information

You define the retention period in the metadata on the Options tab. Your administrator can

set a retention period in the ELO Administration Console (Metadata forms and fields > Entry

options > Lifetime).

Documents only: If you select this option, only documents whose retention period has passed are

marked for deletion.

Documents and folders: If you select this option, documents and folders whose retention period

has passed are marked for deletion.

OK: After clicking the OK button, the deletion markers are set according to the selected options.

Delete permanently

Available in: Ribbon > Organize > System

Important

This function permanently deletes entries with a deletion marker from ELO. Permanently

removed entries cannot be restored. You should be aware that even a differentiated backup

concept only offers a limited option for restoring deleted entries.

In the Delete permanently dialog box, you can specify which entries with a deletion marker you

want to permanently remove from ELO.

Remove deleted entries: All deleted documents and folders are removed from ELO.

Remove deleted document versions and versions of the attachment: All deleted document versions

and deleted attachment versions are permanently removed from ELO.

Deletion date until: Enter a date here. All entries that were deleted before the specified date are

permanently removed from ELO.

Report for entry

Available in: Ribbon > Organize > Properties
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Use this function to open an overview with information on the currently selected entry. Use the 

Configure report dialog box to specify which information to include in the overview. For example,

you can define which actions will be reported or which period the report should refer to.

Choose from the following options:

Number of entries: Specify the maximum number of entries the report should contain.

Date: Enter the period which you want to create the report for.

User: With the User field, you can search for users and groups. As soon as you start typing, a drop-

down menu with possible matches appears. Select the user/group for the report.

Actions: Select the actions you want to be recorded in the report.

Select all: Use this to Select all actions.

Select none: Use this to disable all actions.

OK: Select OK to create the report with the new settings.

The Report dialog box opens.
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This dialog box contains an overview of the actions that were executed for an entry. The name of

the executed action is displayed in the Action name column. You will also see what action was

performed by whom and when.

Go to: The Go to button takes you straight to the respective entry.

Open in read-only mode: Select Open in read-only mode to open the respective document in an

external application.

Clipboard: Use the Clipboard button to copy a selected area in the Report dialog box to the

clipboard. This allows you to save parts of the report in an external document, for example.

Details: Select the Details button to open the Details of dialog box. The Details of dialog box lists

the permissions and group membership of the user who has triggered the respective report entry.

96 ELO Java Client



Information

The Details of dialog box is only available for report entries with the action name 

Indexserver: Login or the action ID 501. This action is only evaluated when you execute a

report for the top repository level and the report settings (Open ELO action) have been

configured accordingly.

Options: Use the Options button to open the Configure report dialog box. Make the changes for the

report in the Configure report dialog box.

Assign replication sets

Available in: Ribbon > Organize > Properties

The replication set is a characteristic that you assign to individual repositories in order to replicate

them in another repository. Each replication set stands for one repository. Replication sets enable

you to synchronize data between multiple locations. The replication sets must have already been

mapped to the entries using the ELO Replication module.

You will find detailed information in the ELO Replication documentation.

In the Replication sets field, you can see which replication sets have already been mapped to the

entry. To add a new replication set, click Add and select a new replication set.
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Please note

Replication sets are inherited upward to parent folders in the repository structure. To

prevent inheritance, select the Start point for replication option in the Metadata dialog box

of the folder you want to replicate.

Add to full text database

Available in: Ribbon > Organize > Properties

Use this function to add the contents of a document to the full text database. The document must

contain full text information. The full text information is written to the full text database and will be

used when searching for documents.

You can view the document content in full text mode in the viewer pane. This enables you to

search the text for specific terms.

Delete from full text database

Available in: Repository work area > Ribbon > Organize > Properties

Use this function to remove a document including its text contents from the full text database. This

means that you cannot find the document with the full text search.

Please note

This function is also available even if the selected document does not contain any full text

information.

Count entries

Available in: Ribbon > Organize > Properties

Use this function to count entries in the currently selected folder. You can also see the amount of

memory that the entries in the selected folder are using.

You can specify which entries you want to count. In addition, you can save the result as a PDF.
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Remove lock

Available in: Ribbon > Organize > Delete

If a user has checked out an entry, it is locked and cannot be edited by other users. Use this

function to remove the lock from a document or folder. Normal users can only remove their own

locks. Administrators can also remove locks from documents set by other users.

Important

Removing a lock may lead to loss of data or changes being overwritten if the entry or

metadata is being edited by another user. To unlock a document for all users, you should

use the Cancel editing function in the Check in dialog box.

For more information on editing an entry, refer to the chapter Edit entry.
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Share and send entries

Send document

Keyboard shortcut: CTRL + M

This function enables you to send a document as an e-mail attachment. A new e-mail opens in

your e-mail program with the document attached. Enter any necessary additional information and

send the document.

Send as ELO link

Available in: Ribbon > Output

This function enables you to send a selected entry as an ELO link. A new e-mail opens in your e-

mail program with the ELO link attached. The recipient can open the entry from the ELO link. The

recipient must have access to ELO.

Send as PDF

Available in: Ribbon > Output > Send

This function converts a document to PDF format. A new e-mail opens in your e-mail program with

the PDF attached.

You can send the PDF with or without annotations (e. g. sticky notes). Select the desired option in

the Send as PDF dialog box.

You can specify your preferred setting in the configuration under Dialog boxes > Annotations when

sending as PDF. You can select the options Confirm via dialog box, Do not embed annotations, or 

Always embed annotations.

Save as ELO link

Available in: Ribbon > Output > Save

Use this function to store the selected entry as an ELO link in your local file system. The ELO link

opens the filing location of the file in ELO. This enables another user to open the entry in ELO. This

person must have access to ELO.

Link with drag-and-drop

Available in: Ribbon > Output > Save

If this function is enabled, you create a link file when you drag an entry from ELO. When you drop

the entry onto the target, you create a link to the entry in ELO. This function allows you to create

links on the desktop or in an e-mail, for example.

Click the entry you want to create an ELO link for.1. 

2. 
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Drag and drop the entry outside of the client, e. g. on your desktop.

Release the mouse button.

The ELO link is created.

Click the link to open the corresponding entry in ELO.

Create external link

Available in: Ribbon > Output > External link

The external link enables users without ELO to access files. You can send the external link to

people outside your company network, e. g. by e-mail. Users can download the files directly via the

link.

Information for administrators

Without additional configuration, the function is only available for computers that are in the

same network or domain as the ELO server. For information on enabling the function for

external devices, refer to the ELO server documentation.

The following options are available to restrict an external link:

3. 

4. 

• 
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Available until: Period during which the link is available to external users

Available indefinitely

Restrict number of downloads to

The following options are available to provide a link:

Send by e-mail: Send an e-mail with the external link to the shared document.

Copy to clipboard: The external link is available in the clipboard for further use, such as in an

HTML document. It can be used with an HTML document, for example.

Information

If you have selected multiple documents, the Copy to clipboard function is not available.

Outlook

You can open an external links overview. You can edit or delete the external links here.

External links overview

Available in: Ribbon > Output > External link

The External links overview dialog box contains an overview of the documents for which an

external link was created. You can edit or delete the external links.

The list is divided into the following columns:

• 

• 

• 

• 

• 
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Type: Document type

Name: Short name of the document the external link refers to.

Created on

Available until: Shows how long the external link is available. If a time is not specified, the

link can be accessed indefinitely.

Access count: Indicates how many times the external link can be accessed. If a number is

not entered, the link can be accessed an unlimited number of times. Every time the external

link is accessed, the number of times it can be accessed again decreases.

Created by

The dialog box has the following buttons:

Go to: Jumps straight to the respective document

Open in read-only mode: Opens the respective document in an external application

Edit external link: Opens the Edit external link dialog box. You can change the settings of the

selected external link here.

Delete external link: Removes the selected external link. The external link is initially marked

red. The link is deleted once you select OK, closing the dialog box. If you close the dialog box

with the Cancel button, the delete action is reversed.

Save table to clipboard

Available in: Ribbon > Output > Save

Use this function to copy the currently selected table entries to the clipboard. The entries can then

be inserted into an external program, e. g. Microsoft Excel.

Alternatively available in: Toolbar > Display options > Table.

Print document

Keyboard shortcut: CTRL + P

This function enables you to print a document selected in ELO.

Print metadata

Available in: Ribbon > Output > Print

You can use this function to print the metadata of a selected entry. Only the basic information that

is also displayed on the Metadata tab is printed.

For more information on metadata, refer to the Important components chapter.

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Fax document

Available in: Ribbon > Output > Print

Use this function to send a document as a fax. This function uses the fax printer configured in the 

Configuration dialog box (Ribbon > User menu [your name] > Configuration > Technical presets >

General > Set as fax printer).

Information

If you don't have a printer with a fax function, the document will be printed.

Export

This function enables you to export folders or documents from ELO. You can also export the entire

repository.

Information

To export the entire repository, select the top level of the Repository work area.
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Use this dialog box to make settings for the file export.

Export target

In the Export target dialog box, you can see the target path for exporting the data set if this has

already been selected.

Select: Opens the dialog box for selecting the target path and specifying the file name. The file

type must be ELOEXP.

Selection

In the Selection area, you can see how many elements (folders or documents) you have selected

for export.
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Filter documents

In the Filter documents section, you can set filters for restricting which documents you want to

export.

By date: If you have enabled this option, you can set a date range for the document date and the

filing date. Only documents within these date ranges will be exported.

By metadata form: If you enable this option, you can select one or multiple metadata forms from

the drop-down menu. Only those documents that were assigned the selected metadata form(s) will

be exported.

Export parameters

In the Export parameters area, you determine which components will be taken into account during

export. You can choose from Folder structure with documents, Folder structure only and 

Documents only. Depending on your selection, you can select additional export options. This

includes All document versions, Keyword lists, Reminders, and the option Replace references with

originals.

Folder structure with documents: If this option is enabled, the folder structure and the documents

in it will be exported.

Folder structure only: If this option is enabled, the folder structure is copied without documents.

Documents only: If this option is enabled, the documents are copied without the folder structure.

Empty folders: If you enable this option, folders that are empty will also be exported.

All document versions: If this option is enabled, all document versions will be exported.

Attachments: If this option is enabled, the current attachments are also exported.

Keyword lists: If this option is enabled, the keyword lists assigned to the metadata forms are

exported with the entries.

Please note

Keyword lists that already exist in the target repository may be replaced during import. If

there are identical metadata forms in the export data set and the target repository, check

whether you want to import the keyword lists as well.

Reminders: If this option is enabled, reminders are also exported with the entries.

Replace references with originals: If this option is enabled, references will be replaced with their

original files during export. If this option is disabled, references are only replaced if the original

documents were not exported with the entries.

Decrypt and export encrypted documents: This option also includes encrypted documents in the

export.
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OK: Starts the export process

Import

This function enables you to import data into the Repository work area.

Please note

You can only import data that was previously exported from an ELO repository.

Source

Select: Use the Select button next to the Source field to choose a source for the import. The source

must be a ZIP or ELOEXP file.

Import target

Define an import target in ELO. You can either select a new target in ELO or copy the old filing

location from the export data set.

Select: Use the Select button next to the Import target field to select an import target in ELO.

Apply from export data set: If this option is enabled, the data set imported will retain the structure

it had when you exported it. The respective structure is displayed next to the option.

Method

The following methods are available for handling GUIDs:
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Information

A globally unique identifier (GUID) is a number with 128 bits used for the unique

identification of documents and folders in ELO on distributed computer systems.

Check GUIDs: When importing the data set, the GUIDs are compared with the GUIDs in ELO. The

following options are available if there are identical GUIDs:

Reassign GUID: Entries that have an existing GUID in ELO are imported with new GUIDs. This

allows you to create duplicates.

Do not import: Entries that have an existing GUID in ELO are not imported.

File as new version: Entries that already have a GUID in ELO are imported as a new version

of the corresponding entries.

Reassign GUIDs of all entries: ELO does not check whether GUIDs already exist during import. All

entries from the import data set are assigned new GUIDs. This allows you to create duplicates.

Options

Keep filing date: To keep the filing date, select this option.

Import keyword list: This option allows you to import keyword lists from the data set.

Re-encrypt documents: If you select this option, a list of encryption keys found by the system

appears. To import entries with an encryption key in encrypted form, enter the corresponding

passwords. If you do not enter a password for an encryption key, entries in the corresponding

encryption key will be imported unencrypted.

OK: Starts the import process

Package dependencies

If a source has package information, its package dependencies are shown in this area.

The source can only be imported if all specified package dependencies are available in ELO.

Information

If any package dependencies are missing, contact your system administrator.

Check package dependencies: You can check the dependencies again, e.g. after the required

packages have been imported.

• 

• 

• 
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File entries via the Intray

You can insert entries using the Insert file function or by dragging and dropping them onto the 

Intray work area and storing them in ELO from there.

Alternatively, you can scan in new documents using the Scan pages or Scan documents functions.

See the Scan documents chapter for more information on this option.

The Intray features a File tab with additional functions for entries in this work area.

You can refresh the view by clicking Refresh.

Use the Delete function to permanently delete the selected document from the Intray.

You can edit documents in the Intray and store them in ELO with the following functions.

Edit document

Keyboard shortcut: CTRL + E

This function opens the selected document for editing in an external program.

Save your changes in the external program. The changes are applied to the document in the Intray.

Edit metadata

The Metadata function (available in: Intray work area > Ribbon > File) enables you to enter

standardized information about a document, making it easier to find in the search. For detailed

information, refer to the chapter Metadata.

The Delete metadata function (available in: Intray work area > Ribbon > File > Edit) enables you to

delete the metadata of a document in the Intray work area. Once a document has been filed to

ELO, you can edit the metadata but not delete it.

File to ELO

Available in: Intray > Ribbon > File

Use this function to file a document from the Intray work area to ELO. Choose the desired filing

location in the dialog box. Use the Go to function to show the filing location in ELO.
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The following functions are available:

New folder: Use this function to create a new folder at the location selected in ELO.

Add: Use this function to create a new favorite. The favorites are listed under your Favorites

and enable you to quickly select a filing location.

Delete: Removes a previously selected favorite.

Automatic filing

Available in: Intray > Ribbon > File > Filing

Use this function to automatically file a document to ELO. You do not have to select the filing target

manually. To use this function, the document must have been assigned a metadata form that

contains a filing definition.

Please note

You cannot edit metadata forms in the ELO Java Client. Contact your administrator if

necessary.

• 

• 

• 
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Serial filing

Available in: Intray > Ribbon > File > Filing

This function enables you to file multiple documents with the same metadata to ELO.

Requirements

There are several documents without metadata in your Intray.

Method

Open the Intray work area.

Select multiple documents by holding down the SHIFT key.

On the ribbon, select File > Filing > Serial filing.

The Metadata for new document dialog box opens.

Define the settings for serial filing. For example, you can use variables to assign a

consecutive number (##) during filing.

1. 

2. 

3. 

4. 
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Information

You can find the possible variables in the tooltip below the short name or in the 

Wildcards section.

Select OK.

The Serial filing dialog box appears.

Choose the folder in ELO that you want to file the documents to.

The following functions are available:

New folder: Use this function to create a new folder at the location selected in ELO.

Add: Use this function to create a new favorite. The favorites are listed under your 

Favorites and enable you to quickly select a filing location.

Delete

Select OK.

Result

The documents are filed to ELO.

5. 

6. 

◦ 

◦ 

◦ 

7. 
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Wildcards

With serial filing, you can use the following wildcards in the short name and other fields.

Wildcards Function Event example

#.# The file name is inserted.

Invoice ELO

Count result

Grenkeleasing

#F# The file name is inserted with the file extension.

Invoice ELO.tif

Count result.pdf

Grenkeleasing.doc

#E# The file extension is inserted.

tif

pdf

doc

#D# The file date and the time are inserted.

2024-07-11 15:28

2020-06-26 11:31

2019-12-02 18:03

## or #1# The document are numbered, starting with 1.

1

2

3

#001#
The document are numbered with three digits, starting with

001.

001

002

003

Image #1#

#E#

The placeholders can be combined with any text and with

each other.

Image 1 png

Image 2 jpg

Image 3 gif

New version

Available in: Intray > Ribbon > File > Filing

Use this function to create a new version of a document from the Intray work area in the 

Repository work area.

Information

You cannot create a new version for a locked or deleted document.

Attach pages

Available in: Intray > Ribbon > File > Filing

Information
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Alternatively, the same function is also available when you drag a TIFF or PDF file to the

repository and drop it on another TIFF or PDF document.

Use this function to add a TIFF or PDF document selected in the Intray work area to a document in

the Repository work area.

Method

Select a TIFF or PDF document in the Intray work area.

Select File > Filing > Attach pages.

The Attach pages clipboard opens.

Select the TIFF or PDF document in the Repository work area that you want to attach the

pages to.

To attach the original document at the beginning of the target document, select Attach to

front. To attach the original document at the end of the target document, select Attach to

back.

Result

The pages are added.

Send to another Intray

Available in: Intray > Ribbon > File > Transfer

This function enables you to send a document to one or multiple users. You can select whether to

keep a copy of the document in your Intray after sending.

Barcode recognition

Available in: Intray > Ribbon > File > Edit

This function starts the automatic barcode recognition process. To use this function, you need the

ELO Barcode module. ELO Barcode allows you to read barcode information in image files, such as

scanned invoices.

For more information, refer to the ELO Barcode documentation.

1. 

2. 

3. 

4. 
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Scan documents

With the Scan to repository function (available in the Repository work area > Ribbon > New >

Scan), you can scan documents directly into the Repository work area. After scanning, you must

enter metadata for the document. The scanned document is filed to the last selected folder in ELO.

Please note

You need to have a compatible scanner installed and selected.

Alternatively, you can use the following ribbon functions within the File tab of the Intray work area:

Scan pages: Use this function to scan individual pages. The pages are filed to the Intray work

area as separate documents.

Scan document: Use this function to scan multiple pages and merge into one document. The

scanned document will be displayed in the Intray work area.

For more information on how to scan and store a document in the Intray, refer to the chapter Insert

document.

The following functions are also available.

Attach pages

The Attach to back and Attach to front functions (available in: Repository > Ribbon > New > Scan)

allow you to add pages to a TIFF document already stored in ELO. You need to scan the pages first.

Please note

You need to have a compatible scanner installed and selected. To check whether a scanner

is installed, select the Select scanner button under Ribbon > New > Scan.

Scan profiles

Available in: Ribbon > New > Scan or Intray work area > Ribbon > File > Scan

Use this function to open the Scan profiles dialog box. In it, you can define profiles for scanning

documents. A scan profile enables you to define settings, such  as which resolution to use or which

format to store the scanned documents in. This way, you can set up a custom scan profile for each

source document.

Scan profiles are used to take the specific properties of documents into account, such as texts,

color images, high-resolution images, different formats, etc.

Information

• 

• 
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You will also find the Print separator pages function in the Scan profiles dialog box. You can

find more information about this function in the Join (separator pages) section.

You can make the following settings:

Available scan profiles

Under Available scan profiles, you can see all scan profiles available to the selected user or group.

New: Creates a new scan profile

Delete: Deletes the selected scan profile

Print separator page: Opens the Print separator page dialog box. In the Print separator page dialog

box, select whether a separator page will be printed with horizontal or vertical bars.

You need a separator page when you scan multiple documents one after the other. A separator

page shows the transition to a new document and ensures that the documents are filed

individually to the Intray work area after scanning.

Name of the profile

Name: Use the Name field to enter the name of the selected scan profile.
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Scan settings

The following settings apply to the scan process. The settings can only be edited if you have

created a new profile or selected an existing profile.

Information

The settings are not supported by all scanners.

Resolution in dpi: In the Resolution in dpi drop-down menu, you can select the resolution (dpi = 

dots per inch) for the scan process.

Color options: In the Color options drop-down menu, select whether you want to create a color,

black/white, or grayscale scan.

Discard blank pages: If this option is enabled, blank pages will not be scanned.

Automatic document feeder: This option is intended for scanner who have an automatic paper

feeder.

Automatic deskew: If this option is enabled, pages scanned diagonally are straightened, if possible.

Duplex scan: This option is intended for scanners that can scan front and back pages.

Brightness: Define the brightness of the scan here.

Contrast: Define the contrast of the scan here.

Threshold: Define the threshold for the scan process here. The threshold is the value that

determines whether a pixel is white or black.

Split pages

The following settings apply to how to handle separator pages.

Separator pages: You can use the drop-down menu to specify whether you want to use separator

pages. If multiple documents are scanned in sequence, ELO recognizes individual documents

based on the separator pages.

Automatically split pages after the following page number: If you select this option, ELO splits the

documents when scanning based on the defined number of pages.

You can also use separator pages. If a separator page is detected, ELO splits the document after

the separator page. The page count begins again after the separator page.

Page format

The following settings apply to the documents being scanned.

Page size: In this drop-down menu, you select which paper format is used.
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Dimensions in: Use this drop-down menu to set the unit of measurement for a user-defined page

format.

Scan clip: If you have selected the option User-defined in the Page size drop-down menu, use the

fields under Scan clip to specify the area that will be included in the scan.

Save document

The following settings apply to the save process.

Image format: Use this drop-down menu to select the file format you want to save scanned

documents in. The following formats are available:

TIFF: Black/white and color scans

JPEG: Only color scans

PDF: Black/white and color scans

Compression: In this drop-down menu, you can specify whether you want to compress the scanned

documents.

Quality: If you have selected the JPEG option in the Compression drop-down menu, you can select

the image quality.

Select scan profile (drop-down menu)

Available in: Ribbon > New > Scan or Intray work area > Ribbon > File > Scan

Use the drop-down menu to select a scan profile for the next scan. Create new scan profiles with

the Scan profiles function.

Select scanner

Available in: Ribbon > New > Scan or Intray work area > Ribbon > File > Scan

Use this function to choose the scanner that you want to use. This function only applies when you

use multiple scanners.

Join pages

Available in: Intray > Ribbon > File

Use this function to join multiple TIFF or PDF files into a multi-page file in the Intray work area.

Information

Annotations on the files are applied to the resulting document.

Method

Hold down the CTRL key and select each document in the Intray in turn.

• 

• 

• 

1. 
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The topmost selected document will be the first page of the new document.

Select Join pages.

Keyboard shortcut: CTRL + K

Result

The individual pages are merged into one document.

Outlook

Use the Split pages function to separate a multi-page document into individual pages.

Split pages

Available in: Intray > Ribbon > File

Keyboard shortcut: CTRL + T

Use this function to split the pages of a multi-page document in the Intray work area. The pages

are numbered as individual documents in the Intray work area. The original is removed. The

function is only available for multi-page TIFF and PDF documents.

Join (separator pages)

Available in: Intray > Ribbon > File > Join

Information

This function is only available for TIFF and PDF files.

Information

Annotations on the files are applied to the resulting document.

You need this function for scanning documents with multiple pages. To select the start and end of a

document, add separator pages to the stack during scanning.

Use empty pages or pages with a black bar as separator pages. You can print the separator pages

via File > Scan > Scan profiles.

If the Join (separator pages) function is enabled, the separator pages are automatically recognized

and the documents are merged into multi-page documents.

Choose from two different merge options for separator pages:

Join using black bar separator pages

Join using blank pages as separator page

2. 

• 

• 
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You will find the settings for the merge options on the Ribbon > User menu [your name] >

Configuration > Advanced settings > Separator page recognition.
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Synchronize entries

Folder synchronization

Available in: Ribbon > Output > External link

The Folder synchronization function enables you to synchronize data in an ELO folder with an

external file system or a mobile device or create a copy of the folder. For example, you can take all

the documents you need to external appointments and then import any changes back into ELO.

Requirement: First you need to map the ELO folder to an external folder via Output > External link

> Configure folder.

ELO checks whether synchronization folders from known cloud service providers are located on

your computer. You are then asked if you want to use these folders as counterparts for folders in

ELO. You can also synchronize folder pairs of your choice. The function automatically synchronizes

data in both directions. In addition to synchronizing documents, it is also possible to map folder

structures.

You can access data in your provider's cloud and edit it from any Internet-ready device. Once you

log back on to the ELO Java Client, you can transfer changes or new files to ELO.

Important

As you can synchronize in both directions, this may cause documents to be deleted on the

computer's file system.

The following describes how to use folder synchronization once you have set up least one folder

pair. You can find more information on how to do this in the section Configure folder.

Method

On the ribbon, select Output > External link > Folder synchronization.
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The Folder synchronization dialog box opens. You will see existing folder pairs and the status of the

last synchronization run.

The dialog box contains the following options:

Start (green triangle): Starts synchronization for the respective folder pair

Please note

If you have enabled the option Synchronize without metadata in the settings and add a file

to the folder in the file system, the file name must start with a plus icon (+) so that it is

transferred to ELO during synchronization. The plus icon in the file name is automatically

removed during synchronization.

Settings (gear icon): Opens the Add folder dialog box You can change the settings for the

respective folder pair here. If the settings for a folder pair were changed, you will see an orange

bar in front of the folder pair in the Folder synchronization dialog box.

Delete (X icon): Removes the folder pair

Information

Deleting a folder pair does not delete the folders themselves. It only removes the folder

mapping.
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Start all: Starts synchronization for all available folder pairs

Please note

If you delete and edit the JSON files, you will lose important data about the synchronization

process.

Configure folder

Available in: Ribbon > Output > External link

The Configure folder function enables you to configure an ELO folder for synchronization with a

folder outside of ELO or save a copy.

To select a folder for synchronization, follow the steps below.

Select a folder in ELO.

On the ribbon, select Output > External link > Configure folder.

In the Add folder dialog box, you specify the target folder in the file system and define the

transmission settings.

1. 

2. 
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ELO folder

Under ELO folder, you can see the folder selected in ELO.

Target in file system

Under Target in file system, you can see the folder selected as the target in the file system. You

can select existing paths from the drop-down menu of the Base folder field. Select New target to

assign a different folder.

Information

The module automatically searches for cloud folders from the following providers: Dropbox,

Google Drive, Microsoft OneDrive, GMX MediaCenter, WEB.DE Online-Speicher, and

SpiderOak Hive. If this kind of folder is detected on the computer's file system, ELO

automatically enters the detected path under Base folder.

Transfer options

In the Transfer options area, you can adjust the synchronization settings. The following settings are

available:

Synchronize, with metadata: The folders selected above are synchronized. An additional file is

stored on the file system for each synchronized entry (folder or document). This additional file

saves the metadata of the synchronized entry in JSON format.

Synchronize without metadata: The folders selected above are synchronized. This option

synchronizes the documents and child folders but ignores the metadata. If you add a file to the

folder in the file system, the file name must start with a plus icon (+) so that it is transferred to

ELO during synchronization. The plus icon in the file name is automatically removed during

synchronization.

Save as copy without metadata: The Save as copy option saves an identical copy of the folder to

the Windows file system but without metadata (GUID, metadata information).

Run automatically when ELO starts: If you select the option Run automatically when ELO starts, the

base folder and ELO folder are synchronized every time ELO starts.

Please note

If you need to synchronize a large number of folders, this will delay all other processes

when starting ELO. For this reason, this function is not recommended for very large

directories that rarely change. In such cases, it makes more sense to create multiple folder

pairs and only set up automated synchronization for selected ones.

Export references as well: Enable the Export references as well option to also export references in

the folder for synchronization.
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Additional information

To start the folder synchronization, select Output > External link > Folder synchronization on the

ribbon..

Manage mobile devices

Available in: Ribbon > Output > External link

This function allows you manage the mobile devices used to transfer documents to the ELO Java

Client with the ELO Connect app. The connection settings are configured in ELO Connect. A new

device will only appear in the Manage mobile devices dialog box after data has been transferred.

You can rename the mobile devices or delete them from the list.

For more information, refer to the ELO Connect documentation.
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ELO Assistant

The ELO Assistant allows you to analyze, edit, or use recognized document content in ELO with

artificial intelligence. You can use the ELO Assistant for documents, folders, and business objects.

The ELO Assistant only accesses entries you have permission to.

You can select predefined functions or enter your own questions and actions. The ELO Assistant

uses the display language of ELO for prompts and responses.

Please note

You can only use language models your administrator has configured for you for the ELO

Assistant. The ELO packages > Solutions > AI prompts documentation is available for

administrators.

Call

Open a document and select the ELO Assistant via the button with the sparkle icon.

Information

You can define a keyboard shortcut for the ELO Assistant under User menu [your name] > 

Configuration > Quick access to functions.
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Interface

1 Select language model: This drop-down menu appears if your administrator has configured

multiple language models. Once a prompt has been submitted, the model is set for the chat. Open

the ELO Assistant again to switch the model via the drop-down menu. If only one model is

configured, no drop-down menu or model name are shown.

2 Input field: Submit a custom prompt for the document. You can also filter by existing actions and

prompts. Suggestions are shown as you type.

Information

If you have submitted multiple prompts for the document, you can navigate through the

message history using the arrow keys.

3 Actions: Only Add documents and Discard are available when you open the ELO Assistant. More

actions appear once you have started a chat.

4 Prompts: The prompts are sent to the configured language model. Five preconfigured prompts

are available as standard. Administrators can add more prompts.

Actions

The following actions are possible:

Add documents: You can add more documents to include in your prompt.• 
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Information

You can only ever select one document in the selection dialog box. If you want to add

multiple documents, select each document separately via Search for more documents

in ELO.

If you select a folder and open the ELO Assistant, all documents in the folder are

shown under Add documents.

Save data: This action is only offered during metadata extraction. It saves the values in the

document's metadata.

Start search: Triggers a search in the ELO repository using the response text. This action only

makes sense with short responses. It can be used to search for customers in the repository,

for example.

Create feed post: This can be used to document who has done what for tracking purposes.

The feed post is visible after the work area has been refreshed.

Try again: If the answer is not satisfactory, you can send the prompt to the language model

again with the same context. This action is only available for the most recently submitted

prompt.

Discard: All actions and prompts are discarded. The ELO Assistant is closed.

Prompts

Preconfigured prompts

Use simple language: The content of the document is written in a clear, easy-to-understand,

and accessible way. This is done by using short sentences and simple words, and avoiding

technical terms or complex sentence structures.

Explain this to me: This prompt generates a concise and structured explanation of the

contents of the document.

Use more professional language: A more formal, objective, precise writing style is used. A

neutral tone is used, as is common in business and academic communication. This

instruction helps tailor content for professional audiences, such as for reports, official

documents, or presentations.

Continue: Prompts the ELO Assistant to continue a text it has started. The language model

uses the style, tone, and content of the existing text to generate a consistent and

thematically appropriate continuation.

Summarize: Instructs the system to reduce the document to its key content. Main points,

arguments, and events are presented in a condensed form.

Please note

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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If the ELO Assistant is unable to return document-specific responses, this may be because it

is unable to access the document's full text. Go to Metadata > Options and check whether

the Add to full text option is enabled.

Prompts created by administrators

Administrators can add more prompts. You will recognize this type of prompt by the sparkle icon.

Example: List course participants

In our scenario, we are working in student administration and want to identify and list the

participants in a course planning document. The custom prompt Course participants has been

created with the following user prompt:

Open the document you want to analyze. In our example, we select a course planning

document that contains course participants.

Select the prompt (here: Course participants) in the ELO Assistant.

The ELO Assistant provides a response in the format requested.

Metadata extraction

The ELO Assistant can help you enter metadata. You can extract metadata from a document and

store it in the corresponding fields of a target metadata form in ELO. Metadata extraction only

works with gen. 2 metadata forms.

Metadata extraction must have been configured by the administrator. The configuration is

described in the administrator documentation ELO packages > Solutions > AI prompts.

You will recognize this prompt type by the combined sparkle icon with a table in the background.

Example: Course data extraction

In the following example, the ELO Assistant will extract course data from a course planning

document. Data should be assigned to fields of different aspects.

Open the document you want to extract data from. In our example, we select a course

planning document that contains course participants.

Select the metadata extraction prompt (here: Course data extraction).

The ELO Assistant shows a table with all configured aspects and assigns the values to the

corresponding field names.

Check whether the values have been assigned correctly. If you do not want to keep certain

values, uncheck the corresponding box.

Which students are enrolled in this course? List them in a table.

1. 

2. 

1. 

2. 

3. 

4. 
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Select the Save data action.

The values are saved in the document's metadata.

130 ELO Java Client


	Table of contents
	Entries
	File entries
	Create folders
	File document
	File a document with drag-and-drop
	Store document with the 'Insert file' function
	Scan a document to the Intray and file it
	Store document with the 'Document from template' function

	Create dynamic folder
	Default index
	Save as default index
	Insert default index


	Edit metadata
	Metadata forms
	Fields
	Icons
	Keyword lists
	Relations

	Additional functions in the 'Metadata' dialog box
	Undo (CTRL+Z)
	Redo (CTRL+Y)
	Automatically enter metadata
	Pin entry to field (Intray only)
	Use last entry
	Insert column index separator
	Load metadata
	Save metadata


	Tabs
	'Basic' tab
	'Extra text' tab
	'Options' tab
	General options
	Options for documents
	Options for folders

	'Permissions' tab
	Permissions for entries in spaces
	Grant a non-member access to an entry

	Outlook

	'Version history' tab
	'Additional information' tab
	Identify personal data
	Delete entries with personal data
	Enter metadata with ELO Click OCR
	List permissions
	Add user/group
	Edit permissions settings
	Members of the group
	Remove permissions


	Edit entries
	Edit entry
	Check out and edit document
	Check out and edit folder

	Load new version
	Document versions
	Edit document
	Discard document changes
	Compare documents
	Convert documents
	Create preview document
	Show preview document
	PDF conversion
	TIFF conversion

	Add attachment
	Attachment versions

	Add and search annotations
	Add annotations
	Add stamps
	Search annotations

	Add margin note
	Create signature
	Check signature
	Test checksum

	Search entries
	Input
	Narrow down search
	Narrow down areas
	Narrow down folders

	Display search results
	Context menu
	Numeric values
	Filters
	Highlighted full text matches
	Display mode for search results

	Search a business object
	Filters
	Enable/disable filter
	Combine filters
	Negate filters
	Remove filters
	Filter with date
	Filter: Numeric

	Save search
	Manage search favorites
	Search metadata
	Form selection
	Dashboards

	Search fields
	Options
	Start search
	Previous searches
	AND/OR search in fields

	Remove from search results
	Recent search requests
	Current folder only
	Show deleted entries

	Organize entries
	Move
	'Move' function
	Drag-and-drop

	Reference
	'Reference' function
	Drag-and-drop

	Copy
	'Insert copy' dialog box
	Insert copy of a document
	Insert copy of a folder
	Permissions


	Monitor changes
	Monitoring overview

	Link
	Move document files
	Selection
	Select document paths
	Settings

	Font color
	Sort order
	Sort manually

	Delete
	Show deleted entries
	Restore
	Delete expired documents
	Delete permanently
	Report for entry
	Assign replication sets
	Add to full text database
	Delete from full text database
	Count entries
	Remove lock

	Share and send entries
	Send document
	Send as ELO link
	Send as PDF
	Save as ELO link
	Link with drag-and-drop
	Create external link
	Outlook

	External links overview
	Save table to clipboard
	Print document
	Print metadata
	Fax document
	Export
	Export target
	Selection
	Filter documents
	Export parameters

	Import
	Source
	Import target
	Method
	Options
	Package dependencies


	File entries via the Intray
	Edit document
	Edit metadata
	File to ELO
	Automatic filing
	Serial filing
	Wildcards

	New version
	Attach pages
	Send to another Intray
	Barcode recognition

	Scan documents
	Attach pages
	Scan profiles
	Available scan profiles
	Name of the profile
	Scan settings
	Split pages
	Page format
	Save document

	Select scan profile (drop-down menu)
	Select scanner
	Join pages
	Split pages
	Join (separator pages)

	Synchronize entries
	Folder synchronization
	Configure folder
	ELO folder
	Target in file system
	Transfer options
	Additional information


	Manage mobile devices

	ELO Assistant
	Call
	Interface
	Actions
	Prompts
	Preconfigured prompts
	Prompts created by administrators
	Metadata extraction




