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WebDAV

ELO WebDAV server address

Information

ELO WebDAV is already integrated into the ELO Indexserver. You can access the ELO

WebDAV directory from the browser. To do this, enter the ELO WebDAV address according to

the following convention:

Connecting using a fully qualified domain name

If you want to connect to a WebDAV server using a fully qualified domain name (FQDN), you must

add the server to the corresponding Local intranet zone:

Open the Internet Options in the Control Panel.

Navigate to the Security tab.

Select the Sites button.

The Local intranet dialog box opens.

Make sure that the Automatically detect intranet network setting is enabled.

Select Advanced.

http://<server name>:<port>/ix-<repository name>/ixwebdav

1. 

2. 

3. 

4. 

5. 
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An additional Local intranet dialog box opens.

Enter the server's fully qualified URL.

The following examples make the difference between a normal URL and a fully qualified URL

clearer:

Normal URL: http://srvtdev02:9090/ix-elo80/ixwebdav

Fully qualified URL: http://srvtdev02.elo.local:9090/ix-elo80/ixwebdav

Select Add.

Close the dialog box.

Close the other dialog boxes with OK.

6. 

◦ 

◦ 

7. 

8. 

9. 
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Using ELO WebDAV on Windows

Windows uses NTLM authentication. This means that passwords are only transferred to the server

in encrypted form.

General note on using ELO WebDAV in Windows

This section contains notes on using ELO WebDAV in Windows.

WebDAV Redirector

In Windows Server 2016 and higher, you must install the WebDAV Redirector component server

side.

You can find more information below under Using WebDAV Redirector.

WebClient

The Windows service WebClient must be running on the client computers. Ideally, the service

should be set to start automatically.

You can set the startup type with the following PowerShell command:

You can start the service with the following PowerShell command:

Data transfer rate

With the default settings, a maximum of 47 MB can be transferred using WebDAV.

To enable a greater transmission rate, adjust the FileSizeLimitInBytes key in the registry.

You can find the key under:

Here you can enter values up to 4 GB (4294967295 bytes).

Next, restart the ELO Web Client service for the changes to take effect.

1. 

Set-Service WebClient -StartupType Automatic

2. 

Start-Service WebClient

1. 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

2. 
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Path length

The maximum path length in Windows is 260 characters.

Connecting Windows Explorer as a network drive (Windows Vista and

newer)

To connect ELO WebDAV as a network drive in Windows (Vista or higher), first open Windows

Explorer.

Open the context menu for Computer or Network.

Select Map network drive from the context menu.

Select a free drive letter and enter the address of your ELO WebDAV under Folder.

Select Finish.

1. 

2. 

3. 

1. 

2. 
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If the user logged into Windows is in Active Directory and exists as a user in ELO, NTLM

authentication is applied automatically and no logon information needs to be entered.

Otherwise, the Windows Security dialog box asks for your user name and password.

Authenticate using your ELO user data.

Please note

In this case, the basic authentication procedure is used, and the password is sent to the

server in plain text. You can secure the data transfer using SSL.

In the registry, change the value of the BasicAuthLevel key to "2" (decimal) accordingly. You

can find the key under:

Please note

Copying documents clears the metadata.

This is because the Explorer sends the PUT command with the target path and content to

ELOix, making it impossible to determine the SORD of the content since there is no SORD

ID.

3. 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
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Slow connection to the WebDAV drive

If the connection to the WebDAV drive and Windows Vista is slow, check the following:

Open the Internet Options in the Control Panel.

Navigate to the Connections tab.

Select LAN settings.

The Local Area Network (LAN) Settings dialog box opens.

Clear the Automatically detect settings option.

Click OK to confirm.

Click OK to close the Internet Options.

In Windows XP

Open My Computer and select Tools > Map network drive.

Select the preferred drive letter.

Select the link to Sign up for online storage or connect to a network server.

The Windows dialog box to add network resources opens.

Select Next.

Select Choose a different network resource.

1. 

2. 

3. 

4. 

5. 

6. 

1. 

2. 

3. 

4. 

5. 

6. 
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Select Next.

Enter the ELO WebDAV address.

Select Next.

Enter a name for the network address.

Select Finish.

Using WebDAV Redirector

Windows Server 2016 and higher

In Windows Server 2016 and higher, you must install the WebDAV Redirector component server

side.

Install as follows:

Use the following PowerShell command:

Check the status of the installation with the following PowerShell command:

If WebDAV Redirector was successfully installed, the value Installed is output in the table.

WebDAV Redirector for versions older than Windows Server 2016

The following link provides information on using WebDAV via WebDAV Redirector (in Windows 7,

Windows 8, Windows Server 2008, or Windows Server 2012):

https://learn.microsoft.com/en-us/iis/publish/using-webdav/using-the-webdav-redirector

Information

Desktop Experience must be installed starting with version 2008.

If you get the error message "System error 67 has occurred. The network name

cannot be found" when adding the ELO WebDAV as a network drive, please check

whether the Windows WebClient service is running and whether Desktop Experience

is installed.

7. 

8. 

9. 

10. 

1. 

Install-WindowsFeature WebDAV-Redirector –Restart

2. 

Get-WindowsFeature WebDAV-Redirector | Format-Table –Autosize

• 

• 
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With the command line

To map ELO WebDAV to a network drive, use the following command in the Windows command

line:

Use the /persistent parameter to define whether the network drive should remain available after

a restart. If you set the value no here, the connection will not be reestablished.

With NetDrive

Select New Site and enter a name for the connection.

Enter the ELO WebDAV address under Site IP or URL.

Open the drop-down menu for Server Type and select the entry WebDav.

Enter the server port into the Port field.

Select the drive letter you want to use.

Enter your ELO logon credentials under Account and Password.

net use Z: \\<host name>:<port>/ix-<repository name>/ixwebdav/persistent:yes

1. 

2. 

3. 

4. 

5. 

6. 

7. 
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To enable SSL encryption, select Advanced and select Use HTTPS.

To use SSL encryption, change the port from 8080 to 443.

Select Save to save the connection.

Select Connect to establish the connection.

With BitKinex

Unlike Windows Explorer and NetDrive, BitKinex does not support WebDAV connections as network

drives. Instead, it uses its own interface. However, BitKinex does support a wide range of features

including the ability to lock folders and files and move and copy files on the server without having

to download the files first.

To connect BitKinex to ELO WebDAV, select Connect or Quick Connect under the File menu

option.

Enter the ELO WebDAV Internet address and the ELO user data.

Select Connect.

8. 

9. 

10. 

1. 

2. 

3. 
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Using WebDAV with Microsoft Office applications

Microsoft Office uses its own WebDAV client. This means you can open an ELO repository in Office

applications like Microsoft Word, Microsoft Excel, and Microsoft PowerPoint without connecting ELO

WebDAV to a network drive first.

In the Open dialog box, enter the Internet address as a file name.

Confirm your input with the ENTER key.

Please note

Do not select OK.

General note on using ELO WebDAV with Microsoft Office applications

With the default settings, some Microsoft Office programs only open documents from a hyperlink in

read-only mode. In the registry, change the value of the OpenDocumentsReadWriteWhileBrowsing key

to "1" (DWORD) accordingly.

You can find the key under:

The following website provides instructions: http://www.webdavsystem.com/server/documentation/

ms_office_read_only.

1. 

2. 

HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Common\Internet
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If a logon dialog box is shown every time you open Office documents, the following settings have

to be changed.

Enable the option Automatic logon with current user name and password (found under: 

Internet Options > Security > Local Intranet > Custom Level > User authentication > Logon)

The ELOix server must be in the intranet zone. This requires two entries:

One with FQN: (e.g.: http://srvtdev.elo.local)

One without FQN: (e.g.: http://srvtdev.elo.local)

In the Windows registry, create the entry (REG_MULTI_SZ) with the name 

AuthForwardServerList under:

As the value, use the host name of the IX server.

This requires two entries:

One with FQN: (e.g.: http://srvtdev.elo.local)

One without FQN: (e.g.: http://srvtdev.elo.local)

Embedding objects from ELO in Microsoft Office applications

ELO WebDAV also allows you to embed files stored in ELO as objects.

• 

• 

◦ 

◦ 

• 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

• 

• 

◦ 

◦ 
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Using WebDAV on Linux

NTLM authentication is not used on Linux. Instead, Linux uses basic authentication. For this reason,

we recommend that you secure the data transfer through SSL.

Davfs2 (command line)

Use the following command:

Replace the placeholders with your own values.

Gnome/Nautilus

In Nautilus, select Locations > Connect to server, or select File > Connect with a server.

Enter the following settings:

Field Notes

Server The server name

Port The port used; default for HTTPS 443

1. 

sudo mount.davfs –o userid=<LINUX-USER> http://<server name>:<port>/ix-<repository name>/ixwebdav/mnt/

2. 

1. 

2. 
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Field Notes

Folder The path to the respective WebDAV directory

User name Name of the ELO account used

Password Password of the ELO account used

KDE/Dolphin

Open the ELO WebDAV address with Dolphin or Konqueror.
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Using WebDAV on MAC OS X

NTLM authentication is not used on Mac OS X. Instead, Linux uses basic authentication. For this

reason, we recommend that you secure the data transfer through SSL.

Command line

Use the following command:

Replace the placeholders with your own values.

Finder

In the Finder, select Go to > Connect to server.

Enter the Internet address of ELO WebDAV into Server address.

Select Connect.

Information

While working with the Finder, many temporary files will be generated, uploaded to ELO,

and deleted again afterwards. Additionally, the files are also created in the ELO root folder.

For this reason, the user who is logged on must have write permissions to the root folder.

Cyberduck

Unlike the Finder, the free Cyberduck tool does not generate temporary files.

After installing Cyberduck, start Cyberduck from your dock or program folder.

Select New connection.

1. 

mount -t webdav http://<server name>:<port>/ix-<repository name>/ixwebdav/<mount point >

2. 

1. 

2. 

3. 

1. 

2. 
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Enter the following settings:

Field/option Notes

Server The server name

Port The port used

User name Name of the ELO account used

Password Password of the ELO account used

Save password Enabled

Path The path to the respective WebDAV directory

1. 
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Using WebDAV on Android

WebDAV File Manager

To connect to ELO WebDAV, you first need to configure a new server (Add Server menu item).

Name: Name of the connection (such as "ELO")

URL: Internet address of ELO WebDAV

Please note

A port number cannot be entered here.

User Name: ELO user name

Password: Password for the ELO account

Select the Optionally specify a port number setting and enter the port.

Select Registration.

WebDAV Nav Lite

Select the plus icon to add a new WebDAV server.

Enter the following values:

Name: Name of the connection (such as "ELO")

Server URL: Internet address of ELO WebDAV

User name: ELO user name

Password: Password for the ELO account

1. 

◦ 

◦ 

◦ 

◦ 

2. 

3. 

1. 

2. 

◦ 

◦ 

◦ 

◦ 
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Using WebDAV on iOS

WebDAV Navigator

Select the plus icon to add a new WebDAV server.

Enter the following values:

Name: Name of the connection (such as "ELO")

Server address: Internet address of ELO WebDAV

User name: ELO user name

Password: Password for the ELO account

Over-the-air

Select Add Server.

Enter the following values:

Display name: Name of the connection (such as "ELO")

URL: Internet address of ELO WebDAV

User ID: ELO user name

Password: Password for the ELO account

1. 

2. 

◦ 

◦ 

◦ 

◦ 

1. 

2. 

◦ 

◦ 

◦ 

◦ 
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Overview: WebDAV clients

ELO WebDAV has been tested with the following WebDAV clients:

Client
Operating

systems

Connected

as drive
LOCK PROPPATCH

MOVE/

COPY
Free Comments

Windows

Explorer
Windows Yes No No N/A

BitKinex Windows No Yes No Yes Yes

WebDrive
Windows,

Mac
Yes Yes No No No

Generates

temp files

NetDrive Windows Yes No No No

Yes, for non-

commercial

use

Cyberduck
Windows,

Mac
No No Yes No Yes

Cross FTP Pro
Windows,

Mac, Linux
No Yes No Yes No

CarotDAV Windows No Yes Yes Yes

TotalCommander

WebDAV plug-in

Windows,

Android
No No No

Free for

Android

Transmit Mac
Drive and

own UI
No No Yes No

Generates

temp files

Finder Mac Yes No No No N/A

Saves temp

files in root

folder and

current

folder

Cadaver Linux No Yes Yes Yes Yes
Command

line

Dolphin Linux No No No Yes Yes

Nautilus Linux No No No No Yes

davfs2 Linux Yes No No No Yes
Generates

temp files

Microsoft Office
Windows,

Mac
No No No No No

WebDAV File

Manager
Android No No No Yes Yes

WebDAV Nav Lite Android No No No Yes Yes

FolderSync Lite Android No No No Yes Yes
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Client
Operating

systems

Connected

as drive
LOCK PROPPATCH

MOVE/

COPY
Free Comments

WebDAV

Navigator
iOS No No No Yes Yes

OverTheAir iOS No No No Yes

Not for

editing. Only

to read and

upload files.
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ELO WebDAV for SAP® ILM

ELO WebDAV 3.1 for SAP® ILM is an add-on integrated in the ELO Indexserver that enables you to

use the ELO Indexserver as the storage location in SAP Information Lifecycle Management

scenarios (ILM).

Please note

The WebDAV ILM metadata form is automatically created to store SAP properties, but only if

the request originates in SAP.

For more information, see:

ELO Suite for SAP ArchiveLink® (SAP NetWeaver® & SAP S/4HANA®) > ELO WebDAV for SAP® ILM
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